It's all about the answers!

Ask a question

RSA 9.7 and RTC 6.0.6: compatible?


Kelly Adams (2112) | asked Feb 15 '19, 8:31 p.m.
edited Feb 15 '19, 8:47 p.m.

Will RSA 9.7 (Eclipse 4.7) work with the RTC 6.0.6 plugin?  


Note that I've checked the compatibility report for RTC, but it only goes up to Eclipse 4.7; RSA 9.7's release info page says RTC 6.0.6 is supported.  However, when I install the RTC 6.0.6 plugin, it fails to work.

I've tried installing the plugin with RSA 9.7, both via Installation Manager and via the Eclipse 'Install New Software' interface.  Both approaches 'work' (i.e.: produce no visible error messages), but the expected RTC views e.g.: Team Artifacts do not appear in the available views after installation/restart.

Update: I did observe the following error in the Installation manager logs:
Eclipse initialize returned with error status=1; could not find eclipse launcher for performing eclipse initialize
- nonsensically, the path it reports for 'eclipse' (e.g.: /Applications/IBM/SoftwareDeliveryPlatform/RSA4WS.app/Contents/MacOS/eclipse)  does in fact exist

Note that I'm installing/running under macOS (10.14.3), if that makes any difference.


Comments
Kelly Adams commented Feb 16 '19, 1:05 p.m.

Another update: I tried with RSA 9.6, and the same version of the RTC 6.0.6 install files (using the Eclipse P2 extension install), and it worked without issue.


So something definitely seems to be wrong with RSA 9.7 and RTC 6.0.6, at least on macOS


Kelly Adams commented Feb 16 '19, 3:14 p.m. | edited Feb 16 '19, 3:15 p.m.

And  yet another update: If I update to RSA 9.6.1, RTC 6.0.6 install fails with this error:


An error occurred while collecting items to be installedsession context was:(profile=IBM Software Delivery Platform com.ibm.sdp.eclipse.ide, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). No repository found containing: osgi.bundle,org.eclipse.core.runtime.compatibility,3.2.200.v20140128-0851 



Kelly Adams commented Feb 16 '19, 3:15 p.m. | edited Feb 16 '19, 3:16 p.m.

 And further digging reveals this org.eclipse.core.runtime.compatibility bundle was removed in Eclipse 4.6 at some point


So RTC 6.0.6 as packaged won't work with RSA 9.6.1 and later it seems; any solution?

Be the first one to answer this question!


Register or to post your answer.