It's all about the answers!

Ask a question

RPE RM Deployed Reports with multiple inherited data sources of the same type


Celia Bengel (116) | asked Feb 14 '19, 9:30 a.m.

 I have created a traceability reports starting from a module

My first data source is "modules"

Next, I have a data source of "_text" to pull in the details about the module requirements which cannot be pulled in from the module context binding.  (attribute and rte version of primary text etc)

Now...I want to get the traced components and pull in similar information.  I'm able to do this by making a data source "_resources", but it does not appear give me all the primary text

According to this white paper, deployed reports must follow strict naming conventions. "modules" "_text" "_resources" etc.

How do I get a second text data source onto the report and still make it deployable?

3 answers



permanent link
Subramanya Prasad Pilar (4.4k14) | answered Feb 15 '19, 8:52 a.m.
You may try appending ptext=true to the request URL so as to get primary text.
To get second text data source, you can use the name of any other artifact type format. It need not be "text" or "_text", though you are using the schema of text artifact type. Another option is to reuse / reconfigure the same "text" data source.

Comments
Celia Bengel commented Feb 19 '19, 1:21 p.m.

Thank you. Unfortunately, I'm still not able to deploy with the following:

modules - being used for the reporting module

Second module data source:  I re-engineered the report to reuse data source "modules".    I'm reading associated (linked) modules to perform a validation step.  I do this step first...and store what I need in variables.  Then open the  data source for the reporting module

_text - taking the reporting details from the reporting module context binding

_resources - this is a trace report

Result:  Report Generation Fail, Review the report data source configuration.

https://www-01.ibm.com/support/docview.wss?uid=swg21685965


permanent link
Hugh Lippincott (174) | answered Feb 18 '19, 9:59 a.m.

 Celia

What versions of RPE and RM are you using?
Your RPE reference is using: "RPE 1.2.1.1 with DNG 4.0.6"
The latest RM/DNG is 6.0.x and newest RPE is 2.1.1  
so I expect many differences from significant progress.


Comments
Celia Bengel commented Feb 18 '19, 4:19 p.m.

I'm using RM 6.0.6 and RPE 2.1.1

I'm trying the approach above for reuse of existing data sources.

The error is "Report Generation Fail, Review the report dat source configuration.   https://www-01.ibm.com/support/docview.wss?uid=swg21685965  "The definition for the Data Source schemas for RRC/DNG is defined in Rational Requirements Composer data sources."

What I think could be the issue is I had multiple data sources  for modules:

modules - the lead data source - module

_modules - a pass thru modules linked to the reporting modules - I'm doing this to pull in an array of artifacts in other modules for a validation step.

_text - more details needed form the "modules" artifacts - (attributes, ptext etc)

_resources - linking associated to the "modules" artifacts - more details such as primary text


permanent link
Celia Bengel (116) | answered Feb 20 '19, 1:30 p.m.

Okay! I finally found the issue -using the rmReporting.logs.   Lessons Learned: Be careful about re-use. Sometimes there may be corruption which could be carried over to a new report


Originally, the report had two passed thru a selected module.  First pass printed the module. Second pass was a trace matrix.

For production, we split the report into 2 parts.  First part was deployed successfully to production.  For the trace matrix, I copied a container form the second half of the report into a new report. 

I ran both reports on production and looked at the logs.  The URL from the first report was fine. The URL from the recycled 2nd half of the report was different and not compatible with the data source schema.  I made a new module data source and removed the old one. Success!

Your answer


Register or to post your answer.