It's all about the answers!

Ask a question

Report Generation Fail error in Rational DOORS Next Generation


Dmitry A. Lesin (23623479) | asked Feb 13 '19, 4:14 p.m.

Hello,

I have Rational Publishing Engine custom report where a part contains data source element with dynamic URI:
RPE Document Studio generates report for RDNG v6.0.5 without a problem. The URI above gets the data correctly applying it in Web browser address field. But after deployment it to RDNG, I have an error:
Report Generation Fail, Review the report data source configuration
I have spent a lot of time, tried many variants but nothing helps. The report fails when trying to query something from for this data source with container or table row elements.
May be somebody knows how fix it. Could you help me please?
Thank you!

3 answers



permanent link
Subramanya Prasad Pilar (4.3k14) | answered Feb 14 '19, 4:07 a.m.

Is that a cross domain template (that retrieves data from other CLM tools apart from DNG)? Can you share the template?


Comments
Dmitry A. Lesin commented Feb 14 '19, 8:24 a.m.

 No, it takes data only from DNG. But there's a specifics. It takes data from current view first, but terms are loaded from another project area with title "Glossary".

I prepared a brief template that works as described above. You can get it by next link:


It generates report in RPE Document Studio with no error, but it throws the error in Jazz:

Error
Thank you!


permanent link
Subramanya Prasad Pilar (4.3k14) | answered Feb 20 '19, 7:37 a.m.

If you are generating report through DNG (using RRDG), you cannot have data source schema names like _artifact, _res+hist. etc. The data source schema name should match any of the supported artifact formats mentioned in https://jazz.net/wiki/bin/view/Main/DNGReportableRestAPI

Data source name must be the same as the service that it is used by in the report template. For example, if the data source name is resources, it will be configured with the URL as follows: https://server:port/rm/publish/resources?resourceURI=artifactURI

If multiple data sources are in the report template, they must begin with an underscore ( _ ). However, one data source must not begin with an underscore ( _ ). That data source is the main data source, and is used to configure the others. The Report wizard uses the main data source to detect which types or artifacts can be included in the report and to filter the available artifacts.


Comments
Dmitry A. Lesin commented Feb 21 '19, 2:28 p.m.

Sorry but it didn't help. I simplified template in accordance to written above but the result is the same. In RPE - there's no error, in Jazz - the error is displayed.

I removed unnecessary data sources, re-import problematic data source as "text" and used URI like next:
I can put template for access again or a single screenshot:
RPE template


permanent link
Glyn Costello (736) | answered Sep 22 '20, 11:15 a.m.

 I have the same problem when using two datasources, one "views" the other "_text"


works in Document Studio with a manually configured Doc Spec, but fails in the Web UI. 

Your answer


Register or to post your answer.