It's all about the answers!

Ask a question

RDNG - problem to generate a report for a view

Leonardo Benevides (266324) | asked Aug 17 '18, 10:38 a.m.
retagged Aug 31 '18, 3:19 a.m. by Minakshi Jaint (5113)

Hi folks!

I'm trying to generate a report of type "Requirements Specification" for a view which their artifacts contain images (common images like diagram, .jpg etc.) and it isn't being possible because in the first step (Select the Report Type) the type "Requirements Specifications" doesn't appears, but if I do the same with artifacts that doesn't contains images, it works fine.

Does someone know the reason why I'm not able to generate this report type? Is there any other way?

The steps to reproduce:

Select the folder that contain the artifacts then click on "More actions" menu > Generate Report for a View.

Rosa Naranjo commented Aug 28 '18, 9:00 p.m.
what version are you trying this on? version + iFix level please.

Leonardo Benevides commented Aug 29 '18, 8:25 a.m.

 Hi Rosa,

CLM 6.0.4, iFix011.

2 answers

permanent link
Kenji Sarai (96029) | answered Aug 24 '18, 3:37 a.m.

I do not have an answer for this particular behavior, but it is generally controlled by Context setting in

In chapter "Manually importing custom document-style report templates for requirements management", you can set Context to specify where "Requirements Specification" is available such as view, module, collection or review. Perhaps you try to generate it from different context, but cannot find it?

Leonardo Benevides commented Aug 28 '18, 1:16 p.m.

Hi Kenji, I took a look at MANIFEST.MF and it appears to be ok. This part is referred to the Requirements Specification type.

Name: reqspec
Location: templates/rrdg/reqspec.dta
Label: %templateMessages_RequirementsSpecification
Description: %templateMessages_RequirementsSpecification_Description
Content-Type: application/octet-stream
Is-Report: true
Context: view, collection

And I had checked the documentation you provided and thanks for that.

I am having a problem to generate a report only if the artifact contain images, diagram... because the type "Requirements Specification" doesn't appears; but if I exclude the images the Requirements Specification appears.

permanent link
Dave Remmel (2517) | answered Aug 24 '18, 8:57 a.m.

Also not the answer, but to add to Kenji's comment, Primary Data Source of your RPE template has a lot to do with this as well. So there are three forces coming together here and they must align for this to work correctly: 1) what artifact you are selecting to start the report generation, 2) Primary Data Source, 3) Manifest Context setting.

Your answer

Register or to post your answer.