It's all about the answers!

Ask a question

DNG Excel import does not update existing artifacts in module


Koak Lodge (1567) | asked Jul 03 '18, 4:20 a.m.

 Rational DOORS Next Generation 6.0.4 iFix009


I have some artifacts in a module which I export using “Export View…” to XLSX. The export includes id and Artifact Type columns, plus Primary Text and some other attributes. I remove the metadata at the bottom and the extra columns to the right (isHeading, parentBinding, and module). Someone else makes modifications to the XLSX, including adding new rows (new row ids are blank).

Then I import the XLSX:
- Import Artifact -> Import requirements from a CSV file or spreadsheet
- Choose the modified XLSX.
- Import requirements into a module -> Pick Module... -> same module they came from
- Update artifacts that match entries, and create artifacts for new entries

I expect to have the existing artifacts updated and the new rows create new artifacts. What I actually get is the same artifacts added again at the bottom of the module, they are NOT updated, plus the newly created artifacts.

For example, before import I have ids in the following order: 100, 101, 102.
After the import: 100, 101, 102, 100, 101, 102, 200 (newly created).

What am I doing wrong?

If there are no new rows, and I import using the folder option instead of module, the artifacts get updated.

5 answers



permanent link
Koak Lodge (1567) | answered Jul 04 '18, 3:47 a.m.

 Thanks Carol for the test. I've done this export/import round trip in the past, with (I think) the same conditions, and I remember it worked fine even with the removed columns and metadata. So I was really confused by it not working now.


I remove the columns and metadata because the exports go to a customer and I don't to confuse/bother them with extraneous data. I see no reason why it shouldn't work as expected, but this is DNG... :(


permanent link
Carol Watson (5116) | answered Jul 03 '18, 1:37 p.m.

 Hi MK,


I just tried this on one of my modules and it worked perfectly.  What I did differently is that I didn't remove anything from the Export, I left everything as it was and added the word "Updated" to one of the artifact rows.  When I imported back into DNG, I made all of the same selections you listed.  After importing and refreshing the page, only the update I made appeared, with no other changes or additions.

I think the isHeading, parentBinding and Module are critical, so try it again and this time leave those just as they appear when you export.  I haven't tried adding new rows yet, but that's going to be my next test.   I'm pretty sure you need to show the Artifact ID under which you want the new artifacts to appear in in parentBinding column so it knows where to place them on the import.

Good luck,
Carol


permanent link
Carol Watson (5116) | answered Jul 03 '18, 2:00 p.m.

Update - I tried adding a new row to the export, and filled in the parentBinding cell with the Artifact ID of the artifact below which I wanted to add my new row.  I also entered the Module # and the Artifact Type.


When I imported back to the module, the new artifact was exactly where I expected it to appear in the module.

Parent artifact was section 1.1 and my new artifact appeared as 1.1-1.  Note that below 1.1, I already had 1.1.0-1 and 1.1-0-2, so it correctly made my new artifact 1.1-1


permanent link
Adrian Haw (223120) | answered Jul 11 '18, 11:19 a.m.
The trick is that you need the parentBinding column in your file - the module and isHeading columns are not mandatory and also the metadata at the bottom is not mandatory.

And before you ask, don't ask. Good luck in finding that one in the docs.

permanent link
honglin (11) | answered Aug 22, 10:18 a.m.

 I have the same issue with Koak Lodge, I export artifact in a module via module view to a csv or xlsx ( it has colums: , and I  did nothing to the file , and then I try to import to the module again, the artifacts are dupliated


so I don't know what is wrong with it?

And I am confused with the round-trip function.


Comments
Adrian Haw commented Sep 17, 7:57 a.m.

Check that your csv file is encoded as UTF8 (no BoM).

Your answer


Register or to post your answer.