It's all about the answers!

Ask a question

Suspicious Profile Settings in RDNG (RM)


Elenilson Chiarapa (138) | asked Jun 28 '18, 4:47 p.m.
retagged Jan 17 '19, 9:17 a.m. by Minakshi Jaint (5113)
Hello Folks,

I'm using the RDNG in version 6.0.4.
I configured the "Manage Suspicious Profiles" feature according to IBM documentation:
I activated the RDNG to perform the trace.
Tracing is enabled to run every minute.
I created a "Suspicious Profile" and enabled all the links in the project area.
Finally, I've updated an artifact linked to another and the "Yes" status does not appear in the RDNG Suspicious field, in any location.

Note: There are no errors in the RDNG, after everything I configured.

Is there anything else to do?

Thank you,

Elenilson Chiarapa 

Accepted answer


permanent link
Sean F (1.3k238141) | answered Jun 28 '18, 5:30 p.m.

As well as setting up the profile and switching on tracking, you also need to select the suspicion profile you want to view from within the project.

While looking at the artifacts view in the project, open the project menu (small icon with 3 horizontal bars in the top right) and choose 'Manage Suspicion' and select the profile you want to use for tracking.

Then you can view suspicion by inserting the suspicion column or any of the other suspicion viewing options.

The other 2 things to be aware of is that

1. indexing the links takes some time after you enable tracking. There is a progress window you can check.
2. You also must not have configuration management enabled for the project as suspicious links is replaced by a different feature in that case

Also The suspicion tracker takes 60 seconds to update so you need to wait a minute to see the results.

Also are you looking at the correct end of the link?

Suspicion only appears on the other end of the link from the artifact that was changed.

If there a link A---->B then when B changes suspicion appears on A and vice versa.

Elenilson Chiarapa selected this answer as the correct answer

Comments
Elenilson Chiarapa commented Jun 29 '18, 11:01 a.m.

Hello Sean,


After following your initial guidelines, it worked correctly.

Thank you very much,
Elenilson 

One other answer



permanent link
Rosa Naranjo (2.9k11623) | answered Jun 28 '18, 5:15 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Hello
The RM indexing page referenced in that topic is https://server:port/rm/indexing

Also check the rm.log for suspicion related activity.

Comments
Elenilson Chiarapa commented Jun 29 '18, 10:55 a.m.

Hello Rosa,


I made the settings that you detailed.
Did not generate error in RDNG log. 

Tks,
Elenilson


Elenilson Chiarapa commented Jun 29 '18, 10:59 a.m.

Hello Rosa,


I made the settings that you detailed.
Did not generate error in RDNG log. 

Tks,

Elenilson 

Your answer


Register or to post your answer.