It's all about the answers!

Ask a question

Getting OAuthentication Error when running RPE report on the server but not through RPE


Richard Good (57427) | asked Jun 21 '18, 1:54 p.m.

Hello,

I'm baffled

I have a report that extracts Data for a RQM Test Plan, this navigates Links to DNG and Defects to RTC, works fine when run from my desktop installation of RPE. However, when I run it from the Jazz server I get a can't redirect error with the URL its trying to navigate to

First thing I do is post the URL into the browser where it gives me the correct XML. What am I doing wrong? The error appears bogus, but the report stops at that error.

2 answers



permanent link
Pierre Bentkowski (36410) | answered Jun 22 '18, 8:54 a.m.
Hi

When you paste in the browser, you are authenticated.
Perhaps the Dynamic Data Source is not set properly in your RPE template.
Can you provide the details setting you have use in the DDS to the DNG or RTC?

Pierre

Comments
Richard Good commented Jun 25 '18, 10:14 a.m.

Hi Pierre,

Thanks for taking the time to answer.

I have inherited my data configuration from the details I use to logon to Qm (single sign on, so these are the same for RTC and DNG) This works for using RPE on my client machine.

A guy called Geoffery Rosenthal had an enhancement request which I found last week, but cannot find now talking about having to have static Datasources related to RM and CCM products when running a cross product RPE report on the server, so I did that and had the dynamic ones inherit the configuration from them. What I have never done is actually set them on the dynamic Datasource itself, so maybe I should try that. Don't think the enhancement request to make it easier to extract data from connected Jazz products was ever accepted. 


Richard Good commented Jun 25 '18, 11:13 a.m.

It seems the inheritance doesn't work for dynamic configurations. If I put my userId and password on the dynamic datasource it works. Don't really want to do that as it's not secure, want to use the logged on users credentials. Not sure which odd operations I have tried have actually helped now.

I've ended up with static datasources for RM and CCM applications whose values I add in RQM and dynamic configurations with embedded password and userId.

Doesn't seem right at all. I wonder if Geoffery Rosenthal still stalks these forums would be nice if he could weigh in... 


Pierre Bentkowski commented Jun 26 '18, 12:14 p.m.
Inheritance does work for dynamic configurations. I use that all the time.
It is hard to help without looking a the template.

For the DDS settings.
I assume that all Data Source names start with '_' expect for the "Entry Point".
In all the Dynamic Data Source you set the: Data/Inherited data configuration is referring to the "Entry Point"  Data Source.
In the Dynamic configuration  tab, you have entered a URI script that is valid (the results string is the same you enter in the browser), all the other filed are left as default.
They are all empty, except the Ignored and the Accept header.

In the Entry Point, which Authentication Type did you use?







permanent link
Richard Good (57427) | answered Jun 25 '18, 10:40 a.m.

Link to Enhancement that seems relevant is here: -

https://jazz.net/jazz/web/projects/Jazz%20Foundation#action=com.ibm.team.workitem.viewWorkItem&id=301790

This does seem a cumbersome process and I couldn't even get that to work.

Your answer


Register or to post your answer.