It's all about the answers!

Ask a question

How can I fix the javascript calculated field error that I receive?


2
1
Andrew Trobec (49712139139) | asked Sep 18 '12, 8:18 a.m.
edited Mar 21 '13, 11:36 a.m. by Ralph Schoon (60.8k33643)
 Hello Everyone,

I have a javascript calculated field that calculates a value based on the values of two other fields.  When trying to run it on one RTC instance (3.0.1.1) it works without any problems.  When I run it on my production machine (also 3.0.1.1), however, I get an error saying "Unable to load <javascript_file>.js".

Is there some sort of server settings that I need to change to allow the script to run?  Please note that the machines have the same RTC installation.  I copied the process configuration (based on the same process template) from one server to the other, and I now get the error.

Could it be that I have to physically copy the javascript file somewhere?

Please help!

Thank you and best regards,

Andrew

Accepted answer


permanent link
Ralph Schoon (60.8k33643) | answered Sep 18 '12, 8:53 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Hi Andrew, you have to enable javascript in the RTC advanced attributes. The property is named "Enable Process Attachment Scripts" you can search for Script in the browser to find it. If it is disabled the script won't load.

If it is enabled, you can try to delete the script in the process attachments and reload it again. I had the impression once I had confused the script engine and after I did this it worked again. I haven't seen that recently, but maybe worth trying.
Andrew Trobec selected this answer as the correct answer

Comments
Ralph Schoon commented Sep 18 '12, 8:54 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

The CCM applications advanced parameters, not the JTS's.


Andrew Trobec commented Sep 18 '12, 9:05 a.m.

Right on the money Ralph, thanks a lot! You win for today! Have all of my internet points!

Your answer


Register or to post your answer.