It's all about the answers!

Ask a question

Check-in operation causes file modification

Gidi Gal (962057) | asked Apr 05 '18, 5:46 a.m.
edited Apr 05 '18, 9:19 a.m.

Hello to the forum members,

I am working with RTC client 6.0.5 connected to 6.0.6 server.
I have a project area (which someone else created), where check-in operation causes "last modified time" of file to be updated (I tries comparing the file in sandbox before and after the operations, did not find changes). This does not happen in other project areas.
If you know of a setting\s which might cause this behavior, I'll be grateful if you comment here.


Ralph Schoon commented Apr 05 '18, 6:37 a.m.

Gidi, a RTC server/client version and type of client is the minimum I would expect in such a question.

Gidi Gal commented Apr 05 '18, 9:21 a.m.

Thanks Ralph, I added the details in my question.

Geoffrey Clemm commented Apr 06 '18, 7:07 p.m.

By "RTC client", do you mean an RTC Eclipse Client?   (As opposed to visual studio, windows explorer, or command line).  Also, by "project area", do you mean "workspace"?  You don't checkin files to a project area ... you check them into a workspace (or if you are using the web client, you check them into a stream).

Accepted answer

permanent link
Ulf Arne Bister (1.3k413) | answered Apr 07 '18, 6:27 a.m.

 Hi Gil,
I take the project area reference to mean "stream or workspace in a particular project area". Things to look out for that might modify files:
- in 6.0.5 keyword expansion was introduced which seems to hinge on load parameter of workspace ( )

- since 6.0.4 we got checkin preconditions and advisors: . Make sure to check if any are activated for that project area and could affect your checkins the way you observer.
- one other thing I could think of is if the delimiter handling has been defined for that project area: - maybe your files start having the "wrong" delimiter and upon checkin that is fixed according to settings?

Just a couple of stabs in the dark in my weekend. If any of this gets you ahead, please mark as accepted and share what worked.


Gidi Gal selected this answer as the correct answer

Gidi Gal commented Apr 25 '18, 10:54 a.m.

Thanks Arne, it was the line delimiter which caused the modification. 

Gidi Gal commented Apr 26 '18, 1:22 p.m.

Hi Arne,

Is it possible to set the line delimiter conversion to ignore specific file extensions ?


2 other answers

permanent link
Ulf Arne Bister (1.3k413) | answered Apr 27 '18, 3:43 a.m.

of course it is. Cp.
"Rational Team Concert source control includes a file properties wizard that you can use when you must change the line delimiter property of one or more files or specify a line delimiter convention to apply to a category of files (based on file name suffix). For more information, see Using the File Properties wizard."

The exact procedure is described in

Basically you add a default line delimiter file property to a class of files by file extensions. If you use the line delimiter property value "none" (as for binary files), then the line delimiter is not looked at and not changed.

permanent link
Gidi Gal (962057) | answered Apr 29 '18, 3:51 a.m.

 Hi Arne,

Thanks for your reply. I did a small test on RTC client 6.0.5:
1) I delivered a small text file (test.txt) with 10 lines with line delimiter \r\n.
2) I set "None" for *.txt.
3) I replace text.txt file with a file with 10 lines separated with \n.
4) On check-in the file was converted to \r\n.

Are you able to to reproduce this behavior ?


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.