It's all about the answers!

Ask a question

RTC 4.0.5 - Script based validator not working after WebSphere Migration


vishnudharan manivannan (1182241) | asked Sep 15 '14, 8:11 a.m.
 Hello All,

We had customized a PA with several script based validators(possibly arnd 25 attributes with script based value sets).

This was in the below environment.

CLM 4.0.5 (CCM + JTS)
IBM DB2 9.7
Tomcat 7.0.32

Now we had to migrate this system to IBM WebSphere 8.5.5. The migration was successfull however ever since that none of the scripts are working for any of the attributes.

We followed the all the steps mentioned for the Websphere migration from tomcat. Is there anything additional to be taken care of ?

Please share your thoughts on the same,

Thanks
Vishnu M

Comments
Ralph Schoon commented Sep 15 '14, 10:20 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I would suggest to look into the log files See: https://jazz.net/wiki/bin/view/Main/AttributeCustomization#Debugging_scripts

To find out what could have happened. I don't have any idea why the scripts should no longer work. Maybe an error message in the log files provides a hint.

One answer



permanent link
Eric Jodet (6.3k5100120) | answered Sep 17 '14, 10:52 a.m.
JAZZ DEVELOPER
 Hello,
I would suspect the scripts are not found.
You may check the CCM.log and search for errors when opening / creating work items.
You may send me your log (eric_jodet@fr.ibm.com) so I can look into it,
as well as your Project Area source as XML.

Thanks,
Eric.

Your answer


Register or to post your answer.