It's all about the answers!

Ask a question

eclipse and rtc plug-in versions


1
1
josep rius (2817) | asked Mar 16 '18, 7:58 a.m.
retagged Mar 16 '18, 1:56 p.m. by Michael Afshar (7014)

Hello,

I have a simple question,
But it's incredibly difficult to find out an answer trough the caos of IBM sites and info fragmentation along articles, wikis, technotes, ...

Which version of rtc plug-in supports a eclipse juno 4.2.2?
As far as I know you can install a 5.0.1 from a p2 repo, without any problem
Can I install a 6.0.2 into the same eclipse (juno 4.2.2) base?

Is there, at any place, something similar to a table relating eclipse versions and plug in versions?
something like that,
Client and server version compatibility: https://jazz.net/help-dev/clm/topic/com.ibm.jazz.install.doc/topics/c_n-1.html

Furthermore, I don't find anymore p2 repositories at any page of releases
https://jazz.net/downloads/rational-team-concert

Accepted answer


permanent link
Adam Wereszczynski (9281932) | answered Mar 16 '18, 8:43 a.m.
edited Mar 16 '18, 8:55 a.m.

Hi Josep,

P2 repositories are now listed in "plain .zip files" section in the "All Downloads" page for a release, under the name of "p2 Install Repository".

The 6.0.2 P2 repository can be found at:
https://jazz.net/downloads/rational-team-concert/releases/6.0.2/RTC-Client-p2Repo-6.0.2.zip

Eclipse 4.2.2 is compatible with a wide range of RTC releases, starting with 4.0.3 up to the current 6.0.5.

If you want to check if a certain RTC version is compatible with Eclipse 4.2.2, you can generate a compatibility report in the below page:
https://www.ibm.com/software/reports/compatibility/clarity/softwareReqsForProduct.html

There is no page which works the other way around (selecting Eclipse version and getting a list of supported RTC versions).


josep rius selected this answer as the correct answer

One other answer



permanent link
kanjbala jawahar (601815) | answered Apr 04, 4:23 p.m.

 Ah I assume, the data given like this kind of shows what version of Eclipse should be installed.


gives data:
Client for Eclipse 3.6.x IDE All (909.52 MB)
Client for Eclipse 4.2.x IDE All (1041.8 MB)

and similarly the download data for RTC 606 here https://jazz.net/downloads/rational-team-concert/releases/6.0.6?p=allDownloads gives this:
Client for Eclipse 4.4.x IDE

So I suppose we could infer in that way.

But it would be nice to actually have this:
(There is no page which works the other way around (selecting Eclipse version and getting a list of supported RTC versions). 
 

Also btw, I wanted to post the above as comment to the answer above, but could not, due to number of character restrictions. Just as fyi.

Your answer


Register or to post your answer.