It's all about the answers!

Ask a question

RQMUrlUtility working with TLS 1.2?


Robert Huet (23113384) | asked Oct 24 '17, 12:48 p.m.

 I get an SSLHandshakeException when trying to use the RQMUrlUtility against our CLM 6.0.2 environment that requires TLS 1.2.  I've tried both Java 7 and Java 8 and get the same error.  Works fine on environments where TLS 1.2 is not required.


Attempting to create SSL_TLS context
java.security.NoSuchAlgorithmException: SSL_TLS SSLContext not available
Unable to create SSL_TLS context, trying SSLv3
RQMUrlUtility: Cannot authenticate to server javax.net.ssl.SSLHandshakeException
: Received fatal alert: handshake_failure

Accepted answer


permanent link
Ted Mayer (47649) | answered Oct 24 '17, 12:53 p.m.

Hello Robert,

The  RQMUrlUtility will work when connecting to an environment that is configured to use TLS 1.2. You would need to add the following to your command:

-Dcom.ibm.team.repository.transport.client.protocol="TLSv1.2"

So the command would look similar to below:

java -Dcom.ibm.team.repository.transport.client.protocol="TLSv1.2" -jar RQMUrlUtility.jar -command GET -user CLM -password <password> -filepath C:\\tmp\\tc.xml -url

Robert Huet selected this answer as the correct answer

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.