It's all about the answers!

Ask a question

Have a problem using Import to Jazz option in eclipse


John Goodson (2158) | asked Jun 05 '17, 4:33 p.m.

I am trying to import just a few items from a very large SVN into Jazz. I am trying to use the GUI import instead of the svndump because the svndump is so large. I have previously done this successfully using RTC 5.x but we have since upgraded to 6.0.3. No matter what I do now when I click the Import to Jazz menu, nothing happens. I can see the following in my eclipse log:


!ENTRY org.eclipse.ui 4 4 2017-06-05 13:08:37.178
!MESSAGE Internal plug-in action delegate error on creation.
!STACK 0
java.lang.ClassNotFoundException: org.tigris.subversion.subclipse.core.ISVNRemoteFolder
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:501)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:421)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:412)
at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)
at java.lang.ClassLoader.loadClass(ClassLoader.java:731)
at com.ibm.team.scm.svn.subclipse.ui.internal.SubclipseImportAction.selectionChanged(SubclipseImportAction.java:55)

and 
!ENTRY org.eclipse.ui 4 0 2017-06-05 13:08:37.187
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NoClassDefFoundError: org/tigris/subversion/subclipse/core/ISVNRemoteFolder
at com.ibm.team.scm.svn.subclipse.ui.internal.SubclipseImportAction.getRepository(SubclipseImportAction.java:45)
at com.ibm.team.scm.svn.subclipse.ui.internal.SubclipseImportAction.run(SubclipseImportAction.java:35)
at com.ibm.team.repository.rcp.ui.utils.AbstractActionDelegate$1.run(AbstractActionDelegate.java:72)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:332)
at com.ibm.team.repository.rcp.ui.utils.AbstractActionDelegate.run(AbstractActionDelegate.java:118)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:251)

I did check and subclipse is installed correctly and that class is in the right location. 

I have tried with a fresh installation of Eclipse, and I even resurrected an RTC 5.0.2 client to try it and I still get the same error. I am wondering if there maybe something incompatible with the latest subclipse and the way RTC is using it.

Hoping for any ideas

Be the first one to answer this question!


Register or to post your answer.