It's all about the answers!

Ask a question

Problem with RTC Query Editor : Not displaying the attribute value instead displaying hyphen"-"

Jazzuser user (681050) | asked May 30 '17, 4:41 a.m.
edited May 30 '17, 4:42 a.m.

Hello All,

We have a custom attribute in a workitem whose type is "Workitem".
We have set some value to this attribute and When we Query the workitems based on this custom attribute,
1. The value is not displayed in the Web Client instead displaying "-" hyphen.
     However the same value is set for the other workitems and it is displayed in the Editor Client  Query.

2. Also this is issue is happening only for some workitems, for rest all, the Query editor is displaying the attribute value. (We also tried syncing the workitem, as this was a custom attribute, but still same issue).

3. When exporting the results of the query to an excel, the value is visible.

What is the issue with the custom attribute of the workitem, behaving weirdly in different Query editors ?

Please let me know why the value is not appearing instead "-" hyphen is appearing.

Please assist.



Don Yang commented May 31 '17, 11:35 p.m.
  • what is your RTC server version and Eclipse client version?
  • do you mean you sync the workitem in Eclipse client and still see the same issue?
  • do you mean that when running a query, even though with the same custom attribute, in some work items, it will show value properly but others will show '-' instead?

Jazzuser user commented May 31 '17, 11:46 p.m.

Thanks for your reply Don.
1. Both RTC Server and Eclipse client version : 6.0.2.
2. Yes, though there was no need of syncing this workitem, as the custom attribute was not added newly(added long back), just to make sure it is synced, we synced the workitem and still the same issue in the Web UI. (To add to this, the value is visible in the Client Query editor and not in the Web UI).
3. Yes, in the Web UI, I queried with the workitem type and the custom attribute with that same value selected for other WIs as well. I was able to get the value for all the WIs queried there, except this workitem which displayed hyphen.

Why is this workitem behaving this way or the Web Query Editor ? Please assist.


One answer

permanent link
Don Yang (7.7k21114139) | answered Jun 01 '17, 10:07 p.m.

There is a similar defect which was fixed in 6.0.1:

I tested with v6,0.2 ifix08 and do see the problem in web client. Only when the custom attribute was created in Web client (work item type) would have this result.
When sync in Eclipse client and refresh the browser, the issue is gone.

You mentioned you have synced in Eclipse client but still see the issue in Web. Did you refresh browser and run the query again after that?

I don't think we need to sync the attribute as per the resolution of defect 363275. So potentially this is a regression in v6.0.2. You may want to raise the issue to support team or you create a new defect work item and see if it can be further investigated.

Jazzuser user commented Jun 02 '17, 12:52 a.m.

Thanks for the reply Don,
Yes, we synced the worktiem in the eclipse client, we have refreshed and ran the query mutilple times, yet same issue. However the value is being populated when exported to excel. We also changed the value of the attribute then set back to original value and then ran the query, still the issue persists.
Thanks Don, we will create a defect for this issue.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.