It's all about the answers!

Ask a question

RTC 6.0.3 Eclipse client isn't showing workitems


Vicente S. (112) | asked Apr 21 '17, 11:38 a.m.
edited Apr 21 '17, 2:13 p.m.

Hello folks, I am facing a rare issue with my RTC 6.0.3 Eclipse client.

I created a trial project at jazz.net and connected it with my client. I could manage some roles and folders in Eclipse client, and I saw the changed reflect at my project, so I guess client and server are properly connected. But, for some reason, I can not find my workitems when I try to manage them in the client.

(Sorry but I can not add an image, because I have no enough reputation, but when I check my work items, it says "unconfigured" between brackets)

Any suggestions?

Thanks in advice.

Edit:

Things I have already checked:

- "Show only custom attributes" check at web client project area configuration is unchecked.
- Default work items are showed at web client project area configuration.
- Changed network connection active provider to "Direct".

One answer



permanent link
Kevin Ramer (4.4k6159178) | answered Apr 21 '17, 12:23 p.m.

There are numerous views that relate to work items, you might at least describe where you're looking.  Did you expand the project in Team Artifacts view down to Work Items/Queries/Predefined ?   Try running a query like "Recently Modified" or "Open Assigned to Me".


Comments
Vicente S. commented Apr 21 '17, 1:34 p.m. | edited Apr 21 '17, 1:37 p.m.

Kevin, thank you for your answer.

Let me be more specific about the issue:

- I created a trial RTC 6.0.3 project at jazz.net.
- I installed the client and connected it to my project
- I made some tests, assigning new users, giving them new roles, ets.
- Then, I tried to create a new work item from Eclipse client, but, when I checked it at Project Configuration / Work items, all options (types and attributes, ennumerations, ets) are marked with a gray font and the text "(unconfigured)
". I can not see any items, even default work items, but when I look for them in my project, they exist.

I guess there is no reason to execute any quary, as far as I didn't create new instances for default or custom work items.

Was I clearer this time?

Additional comment: I know I can manage work items from web client, but my intention is test it using Eclipse client.


Kevin Ramer commented Apr 21 '17, 1:46 p.m. | edited Apr 21 '17, 1:51 p.m.

I sort of suspected you were in the project configuration.  In my experience, those (unconfigured) things aren't untouchable, just that they haven't yet been touched.

"Then, I tried to create a new work item"  -- Do you mean new work item type ?

Did you choose a process template other than "Unconfigured Process" ?  If you chose Unconfigured Process it looks like ALL sections of Project Configuration are (unconfigured).

Did you let the project get initialized ?



Vicente S. commented Apr 21 '17, 2:09 p.m.

"Do you mean new work item type ?" - Yes, that is what I mean, but finally I did not create a new one.

"
Did you let the project get initialized?" - Good question, I suspected the issue had something to do with some pre-configuration I did not made, because, like you said, ALL sections of Project Configuration are "(unconfigured)".

Can you tell me what should I do to initialize my project?


Kevin Ramer commented Apr 21 '17, 2:52 p.m.

I've never seen project area configuration not get initialized if one of the "standard" process templates are chosen.  I deliberately chose "Unconfigured Process" to see the outcome.  The Unconfigured Process puts nothing into the configuration of the project.  It's possible to use, but to do anything requires building things 100% or sharing a process configuration.

A better choice ( if there is one given ) would have been Simple Team Process or even Scrum.   Those will fill in most of the basics.


Vicente S. commented Apr 21 '17, 3:37 p.m.

OK, I think I got what you said and I tried this:

- I went to "Process Templates"
- Then, I chose "Scrum" (just to give you an example)
- Then, I checked work items and this time they have not the label "unconfigured"

Anyway, I have the next issue: elements have weird names, like "%scrum_spec_135". I do not know what "template" should I choose to make it work like I want.

Your answer


Register or to post your answer.