It's all about the answers!

Ask a question

Line delimiter configuration in Windows RTC Client 4.0 after CC Import


Leigh Light (33269) | asked Jun 17 '13, 9:59 p.m.
I recently imported a large number of source code files from base Clear Case into an RTC Project Area.  During import I specified that the line delimiter was to follow the Unix convention (LF only).

I have the RTC Client for both Windows and Linux.  I have configured both clients so that the Preferences->General->Workspace line delimiter is set to Unix and UTF-8 is chosen.  Also, in Preferences->Jazz->CVS->File and Folder,  I unchecked the option "Use platform line endings".  The Preferences->Team->Jazz Source Control->File Properties area will not let me change the line delimiter type from platform to Unix on the Windows RTC Client.  

When I load my workspace/sandbox using the Linux RTC Eclipse Client, my files have the correct line delimiter (LF).  But the linux client is buggy when working with C++ Perspective.  So I try to load the code onto the linux server using the Windows RTC Client, but all my line delimiters change to the Windows line endings (LF+CR).

Can anyone tell me how I can configure the Windows RTC Client so that all the files I load into my workspace use the Unix line delimiter?

Is there a way to apply this configuration to the entire repository?  So that all check-ins and delivered source code use the Unix line delimiter?

Any help with this issue would be much appreciated.

2 answers



permanent link
Matt Lennon (61225) | answered Jun 18 '13, 9:28 a.m.
JAZZ DEVELOPER
 Hi Leigh.

No, currently RTC does not let you do this. You can't use the Windows RTC client to load files with Unix-style line termination, and there is no repository-wide way to configure line termination.

Other users have requested similar functionality. See these Jazz work items and express your interest:


-Matt

permanent link
Geoffrey Clemm (30.0k23035) | answered Jun 18 '13, 11:24 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I just tried this with RTC-4.0.3 and Eclipse-4.2.2, and setting the Preferences->Team->Jazz Source Control->File Properties to be "LF" worked fine for me.  The only twist I encountered was that you could not set the preference at the top level "Text" category, but could do so for all the entries below it (e.g. "*.txt").

Note: This is the only preference you have to set ... at checkin time, whatever you have specified in Preferences->General->Workspace will be overridden by what you have specified in your Jazz_Source_Control preference.   And as I'm sure you know, the CVS preference only affects CVS .. not RTC (I also would have tried setting everything I could find :-).

Also, WRT your initial import with the CC Synchronizer, to tell the CC Synchronizer that you want "LF" terminations, and not the default "Platform" terminations on all the files imported from ClearCase, before doing your first import on a given synchronization stream, set the LINE_DELIMITER_WORKSPACE synchronized stream ClearCase property to be "LF" (by default, it is "PLATFORM").   For details on synchronized stream line delimiter properties, see:
https://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m3/index.jsp?re=1&topic=/com.ibm.team.connector.scm.cc.doc/topics/t_lineterm.html



Your answer


Register or to post your answer.