It's all about the answers!

Ask a question

RTC Web installer fails on linux ubuntu 14.04lts 64bit


André Fachat (132) | asked Feb 21 '17, 7:35 a.m.

Hi,

I am trying to install an RTC plugin into an Eclipse installation. Previously there used to be a p2 zip file which worked very nicely, but that seems to have gone.

The web installer that promises to contain the Eclipse plugin, however, fails to run properly. It prints an error message like:
+ firefox -P Profile_21766 -profile /tmp/IBM_LaunchPad_21766/Profile_21766 -chrome chrome://commonlaunchpad/content/commonlaunchpad.xul(firefox:21891): GLib-GObject-CRITICAL : g_object_ref: assertion 'object->ref_count > 0' failed(firefox:21891): GLib-GObject-CRITICAL : g_object_unref: assertion 'object->ref_count > 0' failed(firefox:21891): GLib-GObject-CRITICAL : g_object_ref: assertion 'object->ref_count > 0' failed(firefox:21891): GLib-GObject-CRITICAL : g_object_unref: assertion 'object->ref_count > 0' failed1487679546526   addons.xpi      WARN    Add-on commonlaunchpad@ibm.com is not correctly signed.1487679546527   addons.xpi      WARN    Add-on commonlaunchpad@ibm.com is not correctly signed.1487679546585   addons.xpi-utils        WARN    Disabling foreign installed add-on langpack-en-ZA@firefox.mozilla.org in app-global1487679546599   addons.xpi-utils        WARN    Disabling foreign installed add-on langpack-en-GB@firefox.mozilla.org in app-global1487679546610   addons.xpi      WARN    Add-on IBM-cck@firefox-extensions.ibm.com is not correctly signed.1487679546611   addons.xpi      WARN    Add-on IBM-cck@firefox-extensions.ibm.com is not correctly signed.1487679546611   addons.xpi-utils        WARN    Disabling foreign installed add-on IBM-cck@firefox-extensions.ibm.com in app-global1487679546624   addons.xpi-utils        WARN    Disabling foreign installed add-on langpack-de@firefox.mozilla.org in app-global1487679546639   addons.xpi-utils        WARN    Disabling foreign installed add-on ubufox@ubuntu.com in app-system-share1487679546931   addons.xpi      WARN    Add-on commonlaunchpad@ibm.com is not correctly signed.1487679546935   addons.xpi      WARN    Add-on IBM-cck@firefox-extensions.ibm.com is not correctly signed.

The server is 6.0.2, so 6.0.3 is out of the question (as far as I understand, there is no p2 zip file there either). For Eclipse Neon I found that the prerequisite should be 6.0.2 (although I may have misunderstood the table).
Base system is Linux ubuntu 14.04 LTS 64bit, with Firefox currently at 51.0.1 (64-bit)

So what do I do?















Accepted answer


permanent link
Donald Nong (14.4k213) | answered Feb 21 '17, 7:07 p.m.

Not sure why you could not locate the p2 package. Here is the direct link.
https://jazz.net/downloads/rational-team-concert/releases/6.0.2/RTC-Client-p2Repo-6.0.2.zip

André Fachat selected this answer as the correct answer

Comments
André Fachat commented Feb 22 '17, 2:36 a.m.

Thanks for the reply! It seems at the hotel yesterday something prevented the download page from loading fully, so it ended after the first zip file... Now (from a different location) I can see the p2 as well again!

Your answer


Register or to post your answer.