It's all about the answers!

Ask a question

RTC Plan View not displayed properly on a dashboard - Excluded Empty Groups are displayed


Isabel Torres (63634) | asked Oct 04 '16, 12:45 p.m.
JAZZ DEVELOPER
I am using RTC 6.0.1

I have setup a Plan view to group the items per Category. I am excluding some items based on "Filed Against (Category)" value.

It displays correctly on the Plan view, only the Categories with items are displayed, however when I add a new widget into a dashboard pulling that plan view, all of the categories grouping sections are displayed... no matter they are not showing any work item.

Is that a known bug? is there a work around? Or I am setting up something incorrectly?

Thank you!!!

Comments
Isabel Torres commented Oct 05 '16, 3:10 p.m.
JAZZ DEVELOPER

I didn't mention that I am adding another Exclusion for Empty Groups... so I can see sections ONLY for groups displaying work items. It works well on the plan view, but not on the dashboard.

Accepted answer


permanent link
Lily Wang (4.9k714) | answered Oct 05 '16, 4:09 a.m.
In my RTC 6.0.1 environment, the categories are always displayed even there's no work item under it. The only condition is the category is associated to the team area which is the owner of the plan.
The "exclude" express filter only filters work items in the plan view.

Isabel Torres selected this answer as the correct answer

Comments
Isabel Torres commented Oct 05 '16, 2:49 p.m. | edited Oct 05 '16, 3:12 p.m.
JAZZ DEVELOPER

thanks Lily for answering...
On my original question I missed to mention that I am Excluding "Empty Groups", so the grouping sections with NO workitems to displayed are NOT  displayed... that works on the plan view, but not on the dashboard... on dashboard I see the entire hierarchy of categories. I just want to see the ones displaying wrokitems.

Is there a way to remove empty categories from the view in the dashboard?


It is causing a lot of confusing to my team members... and I don't want to create a team area for each Category, not need of that... I just want to have separated views for each Category, not all in the same view.

Hopefully you can provide a work around... Thank you!!!


Lily Wang commented Oct 05 '16, 8:00 p.m.

Hi Isabel,

After added the "Exclude Empty Groups", the categories without work item can be hidden. And I saw the same behavior from the Plan View widget.
Could you check if you selected the correct plan view and do a refreshing.


Lily Wang commented Oct 05 '16, 8:01 p.m.

Hi Isabel,

After added the "Exclude Empty Groups", the categories without work item can be hidden. And I saw the same behavior from the Plan View widget.
Could you check if you selected the correct plan view and do a refreshing.


Lily Wang commented Oct 06 '16, 1:26 a.m.

Hi Isabel,

I installed 6.0.1 ifix008 but don't see any issue from plan view widget. There's must be some configuration difference between your setting and my setting.


Isabel Torres commented Oct 10 '16, 8:15 a.m.
JAZZ DEVELOPER

thank you Lily for trying...

I will report the problem to my administrator.

Your answer


Register or to post your answer.