It's all about the answers!

Ask a question

[Closed] RQMCopyUtility: Ignore specific not working and no recurse -need more info

Kumar Kumar (6426) | asked Sep 30 '16, 2:32 a.m.
edited Oct 04 '16, 12:23 a.m.

I wanted to transfer all the Test plans from source server to Destination server except testplan 27.
so i sent below command but still all the testplan including 27 was copied.

java -jar C:\Users\admin\Downloads\RQM-Extras-RQMCopyUtil6.0.2\RQMCopyUtility.jar -s="Source Server/qm/web/console/Function Development (Testing)" -us=ADMIN-pws=ADMIN -d="Destination server/qm/web/console/Function Development (QualityManagement)" -a=testplan,testcase

no-recurse: As for my understanding it will ignore if the testplan already available in destination but it doesn't happen that way. Please let me know how to use -nr.




Kumar Kumar commented Oct 03 '16, 7:22 a.m.

No solution :(

Accepted answer

permanent link
Donald Nong (14.5k414) | answered Oct 03 '16, 11:21 p.m.
The ID is incorrect in your command. It should have been You should see something like this:

Oct 04, 2016 2:16:05 PM logInfo
INFO: Starting: testplan
Oct 04, 2016 2:16:05 PM logInfo
INFO: Ignoring artifact of type: testplan with id:

For the -nr parameter, you can find its explanation in the ReadMe file:
-nr, -norecurse
    Used in conjunction with artifactType. Specify that descendant (referenced) artifacts of the specifed artifact should not be copied.
What it means that, if you specify "-a=testplan -nr", you request to copy testplans only, not their associated testcases or other "children". I don't think it bears anything meaning of "destination".

Kumar Kumar selected this answer as the correct answer

Your answer

Register or to post your answer.