It's all about the answers!

Ask a question

[Closed] RQMExcelImport: Trouble with the Dot (.)

Kumar Kumar (6427) | asked Sep 30 '16, 2:22 a.m.
edited Oct 17 '16, 7:22 a.m.

I am Importing Test Plan and Test cases using RQM Excel Import.
RQM and Excel Import Option Version 6.0.2.

Trouble with loading Custom attributes -
testcase.customAttributes identifier="1 Pre-Conditions".name="Pre-Conditions".type="SMALL_STRING".value=F

No Error reported.
Updating "1 Pre-Conditions" to "1. Pre-Conditions"
testcase.customAttributes identifier="1. Pre-Conditions".name="Pre-Conditions".type="SMALL_STRING".value=F
Throws an Error.
Error: Configuration File, Line 22, Missing end quote: "
Without the Dot(.) no Error and with Dot(.) missing quote error.

As for my understanding "1. Pre-Conditions" is an Internal name which i cant changed.

It is working fine with 6.0.1 but 6.0.2 throws an error.

Looks like there is a bug in Excel Importer version 6.0.2

Please help me to solve this issue.



Kumar Kumar commented Oct 03 '16, 7:23 a.m.

No Solution :(
It looks to be a bug to me.

Accepted answer

permanent link
Lily Wang (4.9k714) | answered Oct 03 '16, 8:25 p.m.
Normally the identifier doesn't contain whitespace. You need to check if the identifier you used is correct.

To get Custom Attribute Identifier follow below steps : 

  1. Create Custom Attributes for TestCase
  2. Create/Update a TestCase and fill value for the Custom Attributes in the TestCase.
  3. Perform GET of this testcase using RQMURLUtility. In the received xml you should see ns2:customAttributes tag similar to below snippet. The value of "identifier" tag is the Custom Attribute identifier. In this case Identifiers for the 2 Custom Attributes are "Custom_attribute_0_" and "Custom_attribute_1_" respectively
Kumar Kumar selected this answer as the correct answer

Kumar Kumar commented Oct 04 '16, 12:29 a.m.

Hello Lily,
I have tried it with both "Custom_attribute_0_" and "Custom_attribute_1_" custome attributes. it works fine.
Problem is when there is a dot(.)

I have created custom attribute "1. Precondition", its identifier is "_._Precondition".
If I tried to export to file also it throws Error: Configuration File, Line 22, Missing end quote: "

If I change the attribute identifier to "__Precondition" and try export file then it works fine.
White spaces not a issue here but dot(.) troubles here.

It was working fine with 6.0.1 but not with 6.0.2.
I think there is a bug so please clarify.


Lily Wang commented Oct 04 '16, 1:36 a.m.

Hi Kumar,

I could reproduce the issue with ExcelImporter 6.0.2. I suggest you contact support to check if this is a product defect.

A workaround is set the Excel cell using value "_._Pre-Conditions" and "1. Pre-Conditions", then change the .cfg file to something like:

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.