It's all about the answers!

Ask a question

[closed] Login page not loading after applying iFix004 to CLM 6.0.2


Luca Martinucci (1.0k284109) | asked Sep 01 '16, 11:11 a.m.
closed Aug 17 '18, 4:27 p.m.
We have recently set up a brand new CLM 6.0.2 server (Linux).
We have then applied iFix004, following the instructions detailed in the readme file.
Upon restarting the WAS profile, we tried to login to the CLM applications (jts and ccm), but the login pages failed to load.
Actually, it seems that the login pages hang: after a 20 minutes wait, we gave up and stopped the WAS profile again.
We then uninstalled iFix004 and installed a previous one, iFix002.
We followed the same instructions; we even ran the same commands.
iFix002 works fine, so I wonder if anyone has installed iFix004 and has encountered any problems.

The question has been closed for the following reason: "Problem is not reproducible or outdated" by lumar Aug 17 '18, 4:27 p.m.

5 answers



permanent link
Daniel Barbour (25017) | answered Sep 13 '16, 4:18 p.m.
The original report is over a week old at this time - with no further comments since Sept. 02 - so it is unclear if the problem has been resolved.  With that said, however, I have the following comments:

To Sany - yes, I have successfully installed iFix004.  I have since reverted to iFix003 - but only because the client we are supporting is configured for iFix003.  For the short time I had iFix004 configured I did not see any differences in behavior with respect to iFix003.

To Luca - Does your installation have Link Index Provider (LDX, which is required if you are also using Global Configurations) and/or does your installation have Link Query Provider (LQE, which is installed if you select Jazz Reporting Service) AND are you running with all applications on the same server machine (i.e. a Development Topology)?

If you have LDX and LQE, and are on the same machine, what you may be running into is heavy CPU usage as the LDX and LQE data structures are being reconfigured which would delay the appearance of the login dialog.  I don't have the specifics  - but I did observe a slower than expected startup the first time we launched the CLM servers after installing iFix003, since you referred to iFix002 I assume you skipped over iFix003 and went straight to iFix004, in which case the iFix003 changes needed to be applied.


Comments
Luca Martinucci commented Sep 14 '16, 5:17 a.m.

I applied this iFix to 2 different CLM environments: one with LDX and LQE installed, and another without them.
I got the same errors on both.
Actually, all CLM applications are running on the same machines, on both environments.
I have opened a PMR for this issue.


permanent link
Luca Martinucci (1.0k284109) | answered Sep 21 '16, 11:04 a.m.
With the help of IBM Support, we have solved the issue.
When we made the initial installation of CLM, we disabled the https transport on the base 6.0.2 CLM applications (by editing the web.xml files).
We were getting the error because, apparently, iFix004 re-enables the https transport automatically, unless you set a custom property in WAS profile (see http://www.ibm.com/support/knowledgecenter/SSCP65_6.0.2/com.ibm.jazz.install.doc/topics/t_disable_server_certificates.html).
With this property set, the CLM applications work even with iFix004 installed.

permanent link
Sany Maamari (13342950) | answered Sep 02 '16, 3:13 a.m.
I'm also interested to know if anyone installed iFix004 successfully, because I will probably install it next week

permanent link
Setembrino Lusa (54) | answered Nov 17 '16, 1:17 p.m.
 I am having Login page not loading after applying iFix006 to CLM 6.0.2
using IE 10 and IE 11... Using Firefox and Chrome it's OK

another server using iFix005 to CLM 6.0.2 works fine using any browser, as this server used to be using iFix005

Any other suggestion ?


Comments
Stephane Couillaud commented Nov 17 '16, 1:32 p.m.

 IBM has released a new iFix called iFix006a since which should fix your issue.  It addresses defect 405498 which appears to be your problem.  Check it out.


Setembrino Lusa commented Nov 17 '16, 2:18 p.m.

 @scouillaud could you provide me the download link, because at fixCentral it's not there...


Stephane Couillaud commented Nov 17 '16, 2:49 p.m.

 Go to https://jazz.net/downloads/clm/releases/6.0.2?p=allDownloads, scroll to the bottom and you'll see iFix006a under interim fixes.


permanent link
Setembrino Lusa (54) | answered Nov 17 '16, 2:53 p.m.
@scouillaud Thank you a lot, applied the iFix006a and it is working as supposed to do