It's all about the answers!

Ask a question

error in Process Configuration Source "schema_reference: Failed to read schema document 'ProcessSpecification.xsd' error using RTC Eclipse Plugin


Michael Angelastro (55416) | asked Jul 19 '16, 12:26 p.m.
when using the RTC Eclipse 5.0.2 plugin for CLM 5.0.2 I get an error in Process Configuration Source tab

"schema_reference: Failed to read schema document 'ProcessSpecification.xsd' because 'platform' access is not allowed due  to restriction set by the accessExternalSchema property

I've uninstalled Eclipse and the RTC Plugin multiple times still the same error.  Its preventing me from making any process configuration changes to a project area.  Any help would be appreciated.  probably means I have some kind of conflicting XML library in your path somewhere.  Also  Java home is configured correctly.

Using a Mac, Eclipse Neon 4.6

Comments
Donald Nong commented Jul 19 '16, 8:53 p.m.

I suggest you use a different machine with a different RTC Eclipse client to check whether the process configuration source itself is corrupted.

3 answers



permanent link
Michael Angelastro (55416) | answered Jul 31 '16, 6:48 p.m.
 I had to revert to Java version 1.7 and installed an older Eclipse version ( Eclipse Luna) and Im able to successfully access the 'Process Configuration' features.  



permanent link
Niels Boumans (33) | answered Mar 07 '17, 4:27 a.m.

This issue can indicate a communication issue when calling the RTC server. 
In our case the HTTP server did not return the correct headers. 
When I called the server directly on port 9443 everything worked fine.


Try this first before re-installing eclipse many times. (Like I just did)

Also the [workspace]/.metadata/.log file can give you information that the error log view inside eclipse doesn't


permanent link
Matthew Inman Cochrane (3837) | answered Mar 28 '17, 11:40 a.m.

When Eclipse is running in a 1.8 JVM, this happens. Whenever I install a new Eclipse, I forget this, research it, remember, and then add...

    -vm
    C:/Progra~1/Java/jdk1.7.0_79/bin/javaw.exe

...to eclipse.ini.


Comments
1
Donald Nong commented Mar 30 '17, 6:30 a.m.

When you add this, Eclipse is running with Java 1.7, which is almost the same as Michael's answer. If you don't specify it, Eclipse will try to use the JRE located in the same path (if available) or the system JRE.


Matthew Inman Cochrane commented Mar 30 '17, 11:11 a.m.

Exactly. One of my coworkers solves this by setting his system environment variables to 1.7. I would much rather my system be using the latest, and just Eclipse use 1.7 if RTC insists.


1
Donald Nong commented Mar 30 '17, 9:47 p.m.

If you use the RTC full package (not an Eclipse plugin), the IBM JDK is included, and used by RTC by default. It is not affected by the System JRE. If you use a standalone Eclipse, IBM has no control over it and you need to ensure that the environment is compatible. The Java 8 support may not get into 6.0.4 based on the discussion on this plan item.
350615: [CLM P1] Support deployments with Java 8 by bundling it

As you can install multiple JRE/JDK on one machine, you can use the latest Java (e.g. Oracle Java 8) as your system default JRE, and a suitable version for RTC.

Note that if you want to compile with Java 8 within RTC, it is still doable, just search the forum for past discussions.

Your answer


Register or to post your answer.