It's all about the answers!

Ask a question

RTC Jazz compatibility with Eclipse and Visual Studio IDEs?


Darrell Reich (917) | asked Aug 30 '16, 12:28 p.m.
Please post a link to the current documentation that shows the current version of RTC Jazz and the versions of Eclipse and Visual Studio plugins supported. Does RTC 6.0.2 work within Eclipse Mars?

We have a very large project with developers all over the world considering upgrading from Rational ClearCase/ClearQuest 7 to RTC Jazz instead of CC/CQ 8. We're using Eclipse Mars 4.5 (2015), Microsoft Visual C++ 2013, & Intel Fortran.

We'd like to be Agile and have an integrated development environment instead of separate versions of  RTC Eclipse and our development environment in separate windows with separate workspace directory sandboxes.

We're spending way too much time with WinMerge diffing folders when we should be using the dashboard to keep the team productive and focused on developing our OSGi bundles with JNI.

https://en.wikipedia.org/wiki/Eclipse_(software)

Alternatively, should we use subversion svn or git/jira? The opensource software is free and seems to have clearer documentation and lots of enthusiastic developers behind it so we're not on the bleeding edge of beta testing each release. All I can find on jazz.net is outdated information for RTC 4 Eclipse support and "error your reputation is not high enough" when I tried to upvote a similar but outdated question. Sorry but I'm not feeling very Agile today.

3 answers




permanent link
Sreerupa Sen (1.0k4) | answered Aug 30 '16, 1:54 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
For an RTC specific report, please go to http://www-969.ibm.com/software/reports/compatibility/clarity-reports/report/html/softwareReqsForProduct?deliverableId=70DF44D0F28511E4989B60FF8B09BCE8&osPlatforms=AIX|IBM%20i|Linux|Mac%20OS|Windows|z/OS&duComponentIds=D005|D004|D002|D003|S001|S006&mandatoryCapIds=30|9|24|35|13|132|42|19|16|26|40&optionalCapIds=133|135|7|5|12|1|242|187|74|19|137|27|4|223&cm_mc_uid=01427124851814683010155&cm_mc_sid_50200000=1472578768#osFamily-4
This is another report similar to the one Alan generated, but is RTC specific. Once in the report, go to the Prerequisites tab and search for Eclipse Runtime Environment or Visual Studio to see the supported versions.

We support VS 2010, 2012, 2013 and 2015  in RTC 6.0.2
We support many Eclipse versions including Mars - 3.6.x, 3.7.x, 4.2.x, 4.3.x, 4.4.x and 4.5.x. Mars is supported by installing RTC as a p2 repository over an existing Eclipse install, it's not bundled with RTC.

And as for switching to other change or configuration management tools, that I guess would be entirely your call. We do not comment on competing tools.

Cheers
--Rupa
RTC Technical Lead

permanent link
Sreerupa Sen (1.0k4) | answered Aug 30 '16, 11:52 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Also the downloads page for a product has a system requirements link that takes you to the requirements wiki for that version. That page is a busy one, so its easy to miss.

Downloads Page

Cheers
--Rupa
RTC Technical Lead

Your answer


Register or to post your answer.