It's all about the answers!

Ask a question

Build Forge-RTC Integration: Error Unable to set working directory to 'D:\BuildFolder\Helloworld_Project\BUILD_2\Helloworld_Project\BUILD_2' (2)


Deepali Deshmukh (601245) | asked Jun 14 '16, 6:04 a.m.
edited Jun 14 '16, 6:05 a.m.
Hi,

I have integrated Build Forge and RTC on windows. I have followed link https://jazz.net/library/article/640.  I am facing Unable to set working directory to 'D:\BuildFolder\Helloworld_Project\BUILD_2\Helloworld_Project\BUILD_2' (2) when project executes .source JazzJBE  in its steps.

I am trying to figure out from where is it taking this path. How to resolve this problem. Can anybody help me.

Thank you in advance.
Deepali Nigade

2 answers



permanent link
Donald Nong (14.3k213) | answered Jun 14 '16, 10:10 p.m.
 This is likely the $team_scm_fetchDestination parameter in the build definition.
https://jazz.net/library/article/195

Comments
Deepali Deshmukh commented Jun 16 '16, 12:55 a.m.

Thank you Donald,

The $team_scm_fetchDestination parameter in the build definition is set to D:\BF_Directory .
Can you please guide me more on the issue 'D:\BuildFolder\Helloworld_Project\BUILD_2\Helloworld_Project\BUILD_2' (2) .



Donald Nong commented Jun 19 '16, 9:23 p.m.

Sorry I don't have a better idea how the path "D:\BuildFolder" comes into place.


permanent link
Deepali Deshmukh (601245) | answered Jun 21 '16, 4:08 a.m.
The Issue is resolved by replacing ".source JazzJBE" with ".source JazzJBEv2"

The error message see in log, reports the following:

Unable to set working directory to 'D:\BuildForgebuildDeepali\HelloBSWProject\BUILD_19\HelloBSWProject\BUILD_19' (2).

The problem is at the following line of the execution:

<run command="runJBE" params="" server="$BFServer" dir="/$BF_PROJECTNAME_PHYS/$BF_TAG" timeout="360"/> 

Since the default directory for the agent is already ="/$BF_PROJECTNAME_PHYS/$BF_TAG, this unnecessary and causes failure in the system. While you can modify this adaptor to resolve your issue (By replace ="/$BF_PROJECTNAME_PHYS/$BF_TAG with just /) or by creating a new adaptor from this template,  there is another adaptor called JazzJBEv2 that has already addressed this issue.

I am not sure why still supply both adaptors, but that could be related to other OS exepecting this format.

Therefore in order to resolve this issue, please replace ".source JazzJBE" with ".source JazzJBEv2" in your environment.

Your answer


Register or to post your answer.