It's all about the answers!

Ask a question

Error!!Unsupported class version-JVMCFRE003


Arumugaraj swamynathan (133) | asked Aug 08 '17, 5:59 a.m.

 Hi all,

       I have installed RTC v6.0.1 and my build toolkit system v6.0.4 on IBM i and while i'm trying to build result in unsupported calss version error.Kindly guide me how to resolve by upgrading to higher version or is it possible to install lower version of build system toolkit on IBM i.My IBM i support java 6.2.6.
Caused by: java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version; class=com/ibm/teami/build/toolkit/listener/IBMiEventFileDependencyListener, offset=6
* at java.lang.ClassLoader.defineClass(ClassLoader.java:273)
* at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:74)
* at java.net.URLClassLoader.defineClass(URLClassLoader.java:563)
* at java.net.URLClassLoader.defineClass(URLClassLoader.java:474)
* at java.net.URLClassLoader.access$300(URLClassLoader.java:77)
* at java.net.URLClassLoader$ClassFinder.run(URLClassLoader.java:1059)
* at java.security.AccessController.doPrivileged(AccessController.java:488)
* at java.net.URLClassLoader.findClass(URLClassLoader.java:452)
* at java.lang.ClassLoader.loadClassHelper(ClassLoader.java:701)
* at java.lang.ClassLoader.loadClass(ClassLoader.java:680)
* at java.lang.ClassLoader.loadClass(ClassLoader.java:663)
* at java.lang.Class.forNameImpl(Native Method)
* at java.lang.Class.forName(Class.java:288)
* at org.apache.tools.ant.util.ClasspathUtils.newInstance(ClasspathUtils.java:249)
* ... 5 more

Accepted answer


permanent link
Kevin Ramer (4.4k6158175) | answered Aug 08 '17, 12:39 p.m.

Most of the time this [Caused by: java.lang.UnsupportedClassVersionError: JVMCFRE003 bad major version ]
means that what you're trying to run in the JRE was compiled with a newer version of Java than is being used by the JRE.   I.e.   The JRE may be v1.7 and you might be building with Java 1.8.

Solution:   Determine the JRE version of the execution environment and build your application with a compatable version.

However, you mention RTC 6.0.1 and 6.0.4 of Build Toolkit... If your RTC server is v6.0.1, you cannot use any client (eclipse, JBE, Build Toolkit, etc)  newer than 6.0.1.

Arumugaraj swamynathan selected this answer as the correct answer

Comments
Arumugaraj swamynathan commented Aug 09 '17, 12:01 a.m.

 Thank you kevin for your quick response and if i use build tookit of version 6.0.1 will it resolve this error as whether this build toolkit of version 6.0.1 will support java 1.6 version?


Ralph Schoon commented Aug 09 '17, 1:49 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

No, because the root cause is most likely that you are running something that was built with a newer version of Java with an older version of Java.

Your answer


Register or to post your answer.