It's all about the answers!

Ask a question

Not able to configure build provider in RQM


Ricky Jay (28325) | asked Mar 28 '16, 7:43 a.m.
Hello,

I am following below steps to integrate builds within RQM to use it
later in the test case execution.

Admin --> Manage Project Properties --> Build Provider --> RTC Integration Provider --> Change & Configuration Management --> Select a CCM project --> Finish

Getting below error when i finish the configuration wizard,

The QM server cannot connect to the CCM server. Make sure that the CCM user ID and password are correct. For more information, open the help system.


However i was able to get the builds in RQM following the same steps before. I have also checked the consumers (Inbound) setting and there is no key provided. Is there anything else i have to check?

Please advice.

One answer



permanent link
Joao Carusi (26314) | answered Mar 28 '16, 9:20 a.m.

1. see if the RTC-RQM friendship has been created

http://www-01.ibm.com/support/knowledgecenter/SSYMRC_5.0.2/com.ibm.jazz.repository.web.admin.doc/topics/tservertoserverestablish.html?lang=en


2. On the Jazz™ Team Server Home page, under Application
Administration, go to the Quality Management (/qm) section and click
Application. Under Configuration on the left, click Advanced Properties.
a) Build Integration Framework
b) Integration Provider

3. In the Quality Management project, click the Admin (Administration) icon in the top, right portion of the banner, and select Manage Project Properties.
> Under Properties, click Build Provider.

Things to check:
- Is it a smart card environment?
- how many RTC project areas you have
- what is the value of RTC advanced property "Maximum Query Result Set Size" .


Comments
Ricky Jay commented Mar 28 '16, 9:39 a.m.

Hi Joao, thanks for the reply.

Followed the step 2 and 3, user/pwd are already set there and the configuration seems to be fine.


Things to check:
"Maximum Query Result Set Size"  is set to 1000.
More than 100 project areas, I have admin rights so can access all.




Joao Carusi commented Mar 28 '16, 12:00 p.m.

Hi Humayun,

Your settings seems to be correct, "Maximum Query Result Set Size"  is > than # of project areas. I cannot think anything else.

What is QM version ? I know that in 6.0.1, steps are different (eg: you need to set consumer key and qm_user needs to have license).

Thank you


Ricky Jay commented Apr 28 '16, 1:24 p.m.

Hi Joao,

We are using version 5.0.2, I was able to resolve this issue by replacing the jazzadmin id/pwd with my user (having jazzadmin rights) in below sections and the issue was resolved.

a) Build Integration Framework
b) Integration Provider


However, it occurs again and seems like if i change the user with some other having admin rights it would work. looks strange !

Any suggestions?


Ricky Jay commented Apr 28 '16, 1:25 p.m.

Hi Joao,

We are using version 5.0.2, I was able to resolve this issue by replacing the jazzadmin id/pwd with my user (having jazzadmin rights) in below sections and the issue was resolved.

a) Build Integration Framework
b) Integration Provider


However, it occurs again and seems like if i change the user with some other having admin rights it would work. looks strange !

Any suggestions?


Joao Carusi commented Apr 28 '16, 1:54 p.m.

The user must have the proper Client Access License and either be a member of the CCM project that you are integrating with for builds, or have the JazzAdmins repository role.
https://hub.jazz.net/clmhelp/topic/com.ibm.rational.test.qm.doc/topics/t_config_rtc_build_integration.html

Your answer


Register or to post your answer.