It's all about the answers!

Ask a question

Change Team Server Port after starting setup


Fred Bickford (28828) | asked Feb 11 '14, 1:09 p.m.
JAZZ DEVELOPER
I have started a custom install, where I specified the URL as https://host.my.company.net:9443/jts (even though the page I was on was https://host.my.company.net:9444/jts/customSetup#/steps/2),

This is a test server, so I proceeded to https://host.my.company.net:9444/jts/customSetup#/steps/5, and tried to change the Discovery URL manually like https://host.my.company.net:9444/rm/scr

The Functional User ID seems to update properly, yet when registering the applications it seems to hardcoded to port 9443 and errors:

HTTP Status 500 - CRJAZ1938E The consumer key and secret could not be validated for the following Jazz Team Server: https://host.my.company.net:9443 Caused by: Connection to https://host.my.company.net:9443 refused Caused by: Connection refused

is there a way to correct this(I cant use 9443 as there is a conflicting application)

Fred

5 answers



permanent link
Ara Masrof (3.1k15) | answered Feb 11 '14, 1:34 p.m.
JAZZ DEVELOPER
Fred,
Take a quick look at the following info-center topic and verify theses steps have been performed

Changing the port numbers for the application server

http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m5/index.jsp?re=1&topic=/com.ibm.jazz.install.doc/topics/t_ports_change.html&scope=null

permanent link
Fred Bickford (28828) | answered Feb 11 '14, 3:13 p.m.
JAZZ DEVELOPER
Ara, the app is answering at 9444, yet the server setup(since I supplied 9443 in the URI) apparently disregards  server.xml port

permanent link
Fred Bickford (28828) | answered Feb 11 '14, 3:13 p.m.
JAZZ DEVELOPER
Ara, the app is answering at 9444, yet the server setup(since I supplied 9443 in the URI) apparently disregards  server.xml port

permanent link
Erica Tran (1.4k6) | answered Feb 11 '14, 4:08 p.m.
JAZZ DEVELOPER
Hi Fred,

It sounds like you use port 9443 in the public root URI.  Once the URI is set, it cannot be changed easily.  I'd suggest starting over since this is a new install. 

permanent link
Dave Evans (1241831) | answered Mar 17 '17, 9:27 a.m.

This is irritating me to no end. I have this problem now on two different applications on two networks. When using the JTS Setup wizard, it seems that it is hard coded to use 9443 for both RQM and DCC. I am running into the exact error as Fred.
I'm using version 6.0.3 iFix 001 on WAS 8.5.5.11.
I confirmed the virtual host has 443 for host *.
I confirmed that server1 has wc_defaulthost_secure is also set to 443.
I restarted the QM server, and even tried reinstalling the app server to WAS after ensuring the ports were set correctly.
Yet when I attempt to register using https://rqm/qm/scr, it brings back an error that https://rqm:9443/qm was forbidden.  Any ideas of other things to check?


Comments
Dave Evans commented Mar 17 '17, 9:58 a.m.

So I found the problem. First of all, I was confused because our JTS is 9443. It was a forbidden attempting to access JTS (not QM, which is 443).
Then I looked into other issues, and I found that the qm_user had been archived! (We have had CLM a long time, but are finally installing QM now). So I unarchived the qm_user and registration was successful, yay!
http://www-01.ibm.com/support/docview.wss?uid=swg21497088


Ralph Schoon commented Mar 17 '17, 10:00 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

 If this is a new, fresh install, there should be no problem setting the public URI to a well known port. We have tons of systems that work that way.


If you try to change the uri after it was already set to another port, this requires a server rename. Also, you should use a reverse proxy that hots the URI if you install a system that is supposed to be used by many users and you should not put all applications on the same host.

Your answer


Register or to post your answer.