It's all about the answers!

Ask a question

Frustration - Cilent version 6.0.2 M2 is not compatible with Server 6.0.1?


Constance Martin-Wilson (912) | asked Jan 28 '16, 3:13 p.m.
This is getting ridiculous.
All I'm trying to do is follow the Junit tutorial and its taking 2 days to do this simple task.

Yesterday I had a RTC Client Version 4, trying to connect to a Server 6.0.1. I was told by RTC, nope you can't do that.

So today I install the latest RTC Client version 6.0.2 M2, and I'm told I can't use that with Server 6.0.1.
Why is this so HARD?


Accepted answer


permanent link
Ralph Schoon (60.5k33643) | answered Jan 28 '16, 3:24 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
edited Jan 28 '16, 3:29 p.m.
No it is not and it never has been.

There is a desire to stay N-1 compatible (if at all possible), but there is no such desire to be kompatible from a server N version to a client N+1 version - let alone a milestone build.

Also recognize that N-1 (Server N and Client N-1) can have a performance and feature penalty.

The client and server refuse N+ and >N to protect users from incompatibility effects.
Constance Martin-Wilson selected this answer as the correct answer

Your answer


Register or to post your answer.