It's all about the answers!

Ask a question

Any setting to disable tagging of keywords in workitem


megha mittal (15112614) | asked Jan 27 '16, 3:56 a.m.
Hi, we are doing import of workitems from any other repository to RTc using item connector framework , but facing issues due to automatic link detection feature by RTC . SO if another repository talk about 'defect xxx' in their comments we dont want it to create link with some 'xxx' workitem in RTC , since defect id's are not same here in RTC..
Is there way to disable it??
Thanks
Megha

2 answers



permanent link
Donald Nong (14.4k314) | answered Feb 16 '16, 7:32 p.m.
This is a problem that many users are facing. Here are the outstanding work items that you can track.
https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/218168
https://jazz.net/jazz/resource/itemName/com.ibm.team.workitem.WorkItem/204058

permanent link
Atul Kumar (1872029) | answered Mar 09 '16, 4:57 a.m.
one hack you can do is put an extra space between the keyword and the number:

for example: replace "task 1" with "task  1"; replace "workitem 2" with "workitem  2".

This confuses the link-creation process :)

Comments
megha mittal commented Mar 09 '16, 5:05 a.m.

Thanks Atul. But will not work in our case as we are doing it programmatically. Was looking for some option in UI at project area level to do it, dont want to make changes to code for it .Because some teams using connector may need it .


Atul Kumar commented Mar 09 '16, 5:17 a.m.

I guess, doing it programmatically (and changing connector code) is the only option till they provide it as a project area configuration.

From within a comment/description text, probably applying a regular expression, searching for "[workitem defect task story] [0-9]+" and replacing it with "[workitem defect task story]  [0-9]+" should work.

If you don't want to make code changes, the only option is to wait till they provide it as a project-area configuration option.

Your answer


Register or to post your answer.