It's all about the answers!

Ask a question

How can you stop the auto-merge from inserting a BOM in a UTF-8 XML file?


Melissa Kivisto (287421) | asked Jan 11 '16, 11:48 a.m.
edited Jan 12 '16, 8:01 a.m.
After performing an auto-resolve on an XML file, the BOM (hex 'ef bb bf') is inserted.
The file is encoded in UTF-8, and this is also specified in the file.

This BOM should not be inserted for UTF-8 and is causing issues for our parser.  How can we stop the auto-merge from inserting this?

One answer



permanent link
Melissa Kivisto (287421) | answered Jan 11 '16, 11:48 a.m.
In the Eclipse client you are performing the merge, change the workspace properties to UTF-8.
This can be done in the preferences, under General>Workspace, then change "Text file encoding". 

Comments
Donald Nong commented Jan 11 '16, 6:05 p.m.

Based on the answer, I would change the subject to "How not to insert a BOM in a UTF-8 file when performing a merge", as the answer does not address the "why".


Melissa Kivisto commented Jan 12 '16, 8:02 a.m.

 Thanks Don! Fixed.

Your answer


Register or to post your answer.