It's all about the answers!

Ask a question

problems occurred running accepting change setes, also resume suspend is not working


Penchala suman (46420) | asked May 30 '16, 3:21 a.m.
edited May 30 '16, 8:31 a.m. by David Lafreniere (4.6k7)
Error_message  We are merging changes from Stream A to Stream B, This is one way merge only (Stream A to Stream B), we see lot of changes coming from Stream A when we’re trying to accept the changes “CRRTCS5092E Accepting the baseline for component ‘Stream A’ would result in too many conflicts in the workspace due to change set reordering. In order to remedy this, you should suspend your outgoing change sets, accepting the baselines and then resume the suspended change sets one at a time and resolve the resulting conflicts” got error message.

As per error message recommendation, we have suspended outgoing changes and then accepted incoming ones, but when we’re trying resume suspended changes are not coming to incoming also we did one by one or all at time also nothing happening when click on resume option.

Any one gone through this issue, please suggest if you have any solution (we are in RTC 5.0.2).

2 answers



permanent link
David Lafreniere (4.6k7) | answered May 31 '16, 10:23 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Can you open up the error log (CTRL+3 and type "error") and see if there is any error logged to that view when trying to resume the change set.

Also can you confirm that the change set you are trying to resume does not already exist in the history of that repository workspace (the one you are trying to resume it into). This could could have happened when you accepted the incoming change sets.
Note: If you try to resume a change set that already exists in that workspace then nothing will happen and the change set remains suspended (it's a no-op). To check if the change set already exists, right-click on the suspended change set and select "Locate Change Sets", now drag&drop the workspace you are trying to resume it into to the "Search Targets" section of the Locate Change Sets editor, it should tell you if the change set already exists or not. If it does, and if you really don't want it to appear in the suspended list, you can right-click it and select "Discard".

Comments
Geoffrey Clemm commented Jun 05 '16, 7:09 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

And assuming that is what is happening (that would be my guess), and if you find it annoying that the resume just silently ignores this case, you might want to add your vote to: "Resume" on a suspended change set is silently ignored (109422)


permanent link
Penchala suman (46420) | answered Jun 09 '16, 9:09 a.m.
Thanks David Lafreniere and Geoffrey Clemm, 

We found a solution to do huge merge without suspended option, 
Update below values on eclipse.ini file and allowed us to accept huge change-sets and we were able to complete our merges successfully.

Before
--launcher.XXMaxPermSize
256m
-Xms100m
-Xmx1024m
-Dosgi.bundlefile.limit=1000

After
--launcher.XXMaxPermSize
512m
-Xms1024m
-Xmx2048m
-Dosgi.bundlefile.limit=1000

Your answer


Register or to post your answer.