It's all about the answers!

Ask a question

Why is the deliver operation greyed out in my Pending Changes?

adrian ngamie (111) | asked Dec 28 '15, 1:37 p.m.
edited Dec 28 '15, 1:58 p.m. by Geoffrey Clemm (30.1k33035)
For a while now, I have not been able to deliver code to RBD, because the deliver option does not highlight.  I tried clearing out my Pending Changes queue, but that removed all changes I have made in my current assignment, so I am back to square 1.

One answer

permanent link
Geoffrey Clemm (30.1k33035) | answered Dec 28 '15, 2:03 p.m.
 I haven't seen this kind of behavior before, but the first thing I'd suggest is to either apply or discard the Pending Patches, and then either discard or check in those unresolved changes, and see if that clears things up.     

adrian ngamie commented Dec 28 '15, 2:08 p.m. | edited Dec 28 '15, 5:20 p.m.

I tried all that before, then tried another deliver,  still can't deliver


Geoffrey Clemm commented Dec 28 '15, 5:27 p.m.

You'll probably have to work with IBM support on this, but a couple of other things to try:
- get your workspace into a state where there are only outgoing change sets (i.e. nothing in the Unresolved folder, and nothing in the Incoming folder)
- create another workspace that is a duplicate of this workspace, and set the flow target of the other workspace to be that stream, and try the deliver from the other workspace.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.