It's all about the answers!

Ask a question

RQM Excel Importer - protocol configuration


alvin kwong (1112) | asked Dec 08 '15, 9:33 p.m.
edited Dec 29 '15, 6:13 p.m. by Geoffrey Clemm (30.0k23035)
 Hi,

I am using RQM Excel Importer add-ins in Excel 2013. When I use RQM Importer to connect to my CLM server (https://<hostname>:9443/qm) with correct username and password, I got a "Validate Credentials" prompt with error message "Invalid server, user name, or password!". The procedure is as follows,
  1. Start Excel 2013
  2. Select "ADD-INS" in menu bar
  3. Click RQM
  4. Click "Export to Repository"
  5. Enter the following
    1. RQM Server: https://<hostname>:9443/qm
    2. Username: <username>
    3. Password: <password>
  6. Click "Validate"
I checked the server log and found the following message,
WebContainer : 21, fatal error: 40: Client requested protocol TLSv1 not enabled or not supported
javax.net.ssl.SSLHandshakeException: Client requested protocol TLSv1 not enabled or not supported

It seems that RQM Importer is using TLSv1 but the server is restricted to use TLSv1.2 and thus no connection can be established. 

======
From CLM 4.0.5, RQM Word/Excel importer starts supporting TLS 1.2. To use this feature, users need to install .NET Framework 4.5 or above, Microsoft Office 2013 and install RQM Word/Excel importer with the installer named  RQMExcelImporterSetupForDotNET45 .
======

I have already installed .NET Framework 4.5, Excel 2013 and RQM Excel importer with installer RQMExcelImporterSetupX64ForDotNET45.msi. Is there any configuration need to be done in order to enable using TLSv1.2 in RQM Excel Importer?

Accepted answer


permanent link
Reshma Ratnani (1.1k1) | answered Dec 09 '15, 12:53 a.m.
JAZZ DEVELOPER
Hi,

Is your Office 2013 32 bit or 64 bit?
Try installing RQMExcelImporterSetup if it is 32 bit or
RQMExcelImporterSetupX64 if it is 64 bit
Geoffrey Clemm selected this answer as the correct answer

Comments
alvin kwong commented Dec 09 '15, 1:36 a.m. | edited Dec 29 '15, 6:13 p.m.

 Hi Reshma,


Thanks for your fast response.

I used to think that the setup is for 64 bit Windows rather than Office. Thanks for pointing it out. The problem is resolved. 

FYI, you may check whether your Excel is 32-bit or 64-bit by following the procedure below,
  1. Start Excel
  2. Click "File"
  3. Click "Account"
  4. Click "About Excel"
  5. You may find it in the first line of the prompt

Your answer


Register or to post your answer.