It's all about the answers!

Ask a question

Error in Application and Friends : Consumer Key "..." for "/rm" was allocated by this server


Cesar Sasaki (511166103) | asked Oct 19 '15, 12:27 p.m.
Hi

I have upgraded to CLM 5.0.2 from 4.0.7,and then uninstall the QM and RM apps. Now I have this warning:

Aplicación: the consumer key "edf7bd4ebb704e5dafa0aa9b88ea98c5" for "/rm" was allocated by this server, when it should have been allocated by the application.
This may indicate that the setup wizard for the application must be executed.

Any help?



Comments
Carlton Knight commented Oct 19 '15, 1:39 p.m.

Why did you uninstall QM and RM.  Did you also un-register the applications?  Is it safe to assume that you will no longer be using the RM or QM applications going forward?


Cesar Sasaki commented Oct 19 '15, 1:56 p.m.

Hi Carlton

I uninstall before I ran the upgrade because it is easier to upgrade from 4.0.7 to 5.0.2 without rm and qm.

I will be using rqm and qm now on 5.0.2 that is why I need them.

I read something about "repotools-jts -rebuildindices "

Accepted answer


permanent link
Abraham Sweiss (2.4k930) | answered Oct 19 '15, 7:49 p.m.
Hello Cesar,

Since RM has been uninstalled, were the friendships with jts also removed.  If not, please check under registered applications and the friends sections on the jts server and remove any links to rm.

-Abraham
Ralph Schoon selected this answer as the correct answer

Comments
Cesar Sasaki commented Oct 20 '15, 1:07 p.m.

Hi Abraham
On Registered Applications I have this :


Should I remove the ones I uninstall?

4 other answers



permanent link
Charlie Seo (22126) | answered Oct 19 '15, 7:51 p.m.
edited Oct 19 '15, 7:51 p.m.
There would be a few options to address this issue but re-register applications should be a good one to try. 

https://jazz.net/wiki/bin/view/Main/ReregisterApplicationTool

Since there seem to be some consumer keys lingering in the repository, you might need to remove it before re-register RM and QM. In your case, the following actions to delete the unwanted keys might be required. 

-repotools -listStorageKeys
-repotools -setStoragekeys






permanent link
Abraham Sweiss (2.4k930) | answered Oct 20 '15, 1:29 p.m.
Hi Cesar,

Yes, since rm and qm have been uninstalled, there is no need to have these applications registered with the jts server.

-Abraham


Comments
Cesar Sasaki commented Oct 20 '15, 1:45 p.m.

Hi Abraham

It seems that I did not uninstalled the qm and rm but I upgraded the qm and ccm only. I have installed all the apps for 5.02 and 4.07. Should I uninstall the 502 rm  do something and then  install it again?


permanent link
Abraham Sweiss (2.4k930) | answered Oct 20 '15, 1:52 p.m.
Cesar,
In 4.0.x, the rm  application use to be located in the same DB as the jts server.  IF you are going to keep the rm application, you will njeed to continue with the upgrade of rm, so the relavent bits can be pulled from the jts DB and put in the rm db.
-Abraham

permanent link
Shawn Chaney (111) | answered Jul 24 '18, 9:23 a.m.

Is this related to the order of which the servers are rebooted? I've been having this recurring problem over the last couple of days and my solution has been to reboot. Today that didn't work though. I moved to a prior instance of my JTS server and along with the booting up sequence DB server, JTS, Then RTC, RM and JRS together this worked. I don't don't know if my users are able to do anything to JTS to make it have this problem


Comments
Ralph Schoon commented Jul 24 '18, 12:41 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

This post is 3 years old....

The user uninstalled applications but the registration/friendships were not removed. So the JTS was not finding the applications.

With respect to reboot if you only boot JTS and the other applications are not available I would expect to see warnings.


Shawn Chaney commented Jul 24 '18, 12:50 p.m.

I booted all the servers. My system is unstable and I can't figure out why. Right now its gold but everyday something has to be done to get it there


Ralph Schoon commented Jul 24 '18, 2:29 p.m. | edited Jul 24 '18, 2:30 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Consider to work with support, if possible. I am not sure how you can solve this in the forums. Posting answers to really old questions in the forum might not be the best way. Bugs that might have been in older versions might not be in current ones.

Your answer


Register or to post your answer.