It's all about the answers!

Ask a question

Not able to find 'Add Subcomponet' new functionality in RTC 6.0.1

prabhu Rao (1126) | asked Oct 07 '15, 1:54 a.m.


We have installed RTC 6.0.1M4 and completed JTS setup, then created project area, streams and components in RTC 6.0.1.

But we are not able to find the Sub Component addition option in RTC 6.0.1 eclipse client as per the below help document link for Add Subcomponet new functionality.

Please advise and help on this to achieve this new functionality in RTC 6.0.1.

Please look at the following link :    Adding and removing components in hierarchies Under Organizing components into hierarchies.

2 answers

permanent link
Geoffrey Clemm (30.1k33035) | answered Oct 07 '15, 10:59 p.m.
Note that the property is "Enable Hierarchical Components" (not "Enable Distributed SCM").   But based on your screen shot, you set the right property.  

But in your second screen shot, you are looking at a stream, which is not where you can add subcomponents ... you need to do that in a workspace, not in a stream.  In particular, go to the My Repository Workspaces section of the Team Artifacts view.  Right click on one of the components in one of those workspaces, and you should see the Add Subcomponent operation.

Add Subcomponent operation

prabhu Rao commented Oct 12 '15, 1:56 a.m. | edited Oct 14 '15, 7:34 p.m.

Thanks a lot Geoffrey Clemm,

It helped me to achieve this new functionality...!

- Prabhu.

permanent link
Shradha Srivastav (348413) | answered Oct 07 '15, 2:05 a.m.
Hi Prabhu,

To create component hierarchies, move to ccm/admin page -> Advance properties -> search for "Enable Distributed SCM". Set it to true, restart the eclipse client and you will be able to create sub-components.


prabhu Rao commented Oct 07 '15, 5:45 a.m.

Hi Shradha,

Thanks for quick response.
I am still not able to find the "Sub Component addition" option even after "Enable Distributed SCM" is set to true.


Naveen Tyagi commented Oct 07 '15, 6:06 a.m.

I am also still not able to find the "Sub Component addition" option even after "Enable Distributed SCM" is set to true as shown in the screen captures.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.