It's all about the answers!

Ask a question

How to enable new features i.e. Nested Loading, Component Hierarchies in RTC version 6.0?


2
1
Nikita Dhande (3519) | asked Sep 10 '15, 4:40 a.m.
 How to enable new features i.e. Nested Loading, Component Hierarchies in RTC version 6.0?  

Accepted answer


permanent link
Ralph Schoon (61.6k33643) | answered Sep 10 '15, 5:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I think this is done as follows:

Open mange the server for the CCM application. Go to the advanced properties section. Browser search Hierarchical or scroll down to the SCM section.

Set Enable Hierarchical Components to true and save.


Nikita Dhande selected this answer as the correct answer

Comments
Nikita Dhande commented Sep 10 '15, 5:47 a.m.

 Thanx!! It's done.


Nikita Dhande commented Sep 10 '15, 6:07 a.m.

 But in the Eclipse client, I can see the option now but it is disabled by default. How to enable it? I tried creating a new component but on right-clicking it, that option is showing disabled.


Ralph Schoon commented Sep 10 '15, 6:15 a.m. | edited Sep 10 '15, 6:16 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I did the change and I can now add a sub component to a component in a stream in my Eclipse Client.


Krzysztof Kaźmierczyk commented Sep 10 '15, 6:20 a.m.

Hi Nikita,
You need to upgrade RTC eclipse client to 6.0 to see it there. Did you already upgrade that?


Nikita Dhande commented Sep 10 '15, 6:36 a.m.

Hi,


Yes the current RTC version is 6.0.

2 other answers



permanent link
David Dulling (18134) | answered Sep 14 '15, 4:20 p.m.
Hi

I'm having a problem with this too. I set the Advanced Property as suggested and even restarted the server and client but still I don't see the options to add subcomponent

I'm running with the 10 free developer licences. Could this be a reason?

Thanks

David

Comments
Ralph Schoon commented Sep 15 '15, 2:27 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

I tried for my answer using a 10 free license key, as far as I can tell. It seems to be working for me.


2
Angelo Corna commented Oct 19 '15, 8:54 a.m.

David, you need to have at least 2 components on your workspace.
I had the same problem because on my test environment (RTC 6.0) there was only a component defined. Creating another component the option become enabled.


permanent link
David Dulling (13721112) | answered Oct 20 '15, 4:41 p.m.
Hi, Angelo

Thanks for your reply. Yes, I can confirm I am able to nest components.

Cheers

David

Your answer


Register or to post your answer.