It's all about the answers!

Ask a question

"Modified Date" field update in workitem


Mohanraj Ragupathi (54418) | asked Aug 06 '15, 5:40 a.m.
 We are using RTC 502. When I change my Summary or discussion or tag attributes in defect work item (in Resolved / Closed state)  in Eclipse IDE , the "Modified Date" is not getting updated. I have checked this in "History" tab. It is not reflecting.

If I open the same workitem in webclient (I use Chrome here), if I modify the same attribute again and "save" it, I am seeing the "Modified Date" update in the "history". 

Is there is any issue? What basis this "Modified Date" is getting updated? 

Comments
Arun K Sriramaiah commented Aug 07 '15, 5:04 a.m.

 Hi Mohanraj,


1) Verify and open from the different eclipse workspace 

2) Do you have any plugin deployed in the eclipse client, remove and try again.

3) Check do you have any scripts used, remove and try.

Regards,
Arun.



2 answers



permanent link
Arun K Sriramaiah (3.2k12263) | answered Aug 07 '15, 5:06 a.m.
  Hi Mohanraj,

Modified Date should work in way for both eclipse and web client if its OTB.

1) Verify and open from the different eclipse workspace 

2) Do you have any plugin deployed in the eclipse client, remove and try again.

3) Check do you have any scripts used, remove and try.

Regards,
Arun.



permanent link
Mohanraj Ragupathi (54418) | answered Aug 07 '15, 8:43 a.m.
 HI Arun,
               Modified Date is OTB only.

on the other points

1) Same eclipse workspace only we are using. What is the different if we use different workspace?
2) Yes, we have in-house plug-in. But that won't be triggered or invoked in this state transition condition.
3) Yes, this question is based out of the script we are looking for. Basically we want to capture the Modified date as "closed date" in "closed" condition. This is working in Webclient but not in Eclipse client. So the script is not a problem.



Comments
Ralph Schoon commented Aug 07 '15, 8:56 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Please be aware that the Web UI uses the browsers script engine and the Eclipse client uses one that is shipped with RTC. They are different and this means your script could have a problem and cause issues. Use Console.log to print data and check the condition works in the Eclipse client.

Your answer


Register or to post your answer.