It's all about the answers!

Ask a question

Anyone seen these errors configuring the Data Collector in CLM 6.0?


Davyd Norris (2022914) | asked Aug 02 '15, 12:43 a.m.
Hi all,

I'm setting up a CLM 6.0 instance and went to run some RQM reports, only to find I needed to set up the Data Collection Component.

I followed the instructions, hit "Discover" and it populated the resource groups with my apps. I then added the necessary passwords for each resource and tried to save and got the following error:

Unable to load /dcc/datacollection/resource/resourceGroup/ status: 409

I have been banging my head against this for a couple of days now trying to get it to work but I can't get the resources to save, and therefore I can't run most of the RQM reports - in fact it doesn't even populate the query selection boxes with options such as Plans, Teams etc.

I can run all collection jobs and the ones that do not require Resource Groups run just fine

Comments
Donald Nong commented Aug 02 '15, 7:46 p.m.

Any more detailed messages in the log files?


Davyd Norris commented Aug 02 '15, 7:55 p.m.

Hey @dnong,

I only found out about the need to configure the dcc whilst in the middle of a demo on Friday :-(

Going to have a lot more of a play today and will grab logs - there were also other errors that came up and I want to capture those too.

Accepted answer


permanent link
Francesco Chiossi (5.7k1719) | answered Aug 03 '15, 2:37 a.m.
Hello Davyd,

I've seen this issue in my environment before.
The workaround is:
  1. Delete all the resource groups
  2. Create a new one (making sure to enter correct credentials before saving)
  3. Save
  4. Repeat 2 and 3 for the remaining groups.

This is tracked in an internal defect

Best Regards,

Francesco Chiossi

Davyd Norris selected this answer as the correct answer

Comments
Davyd Norris commented Aug 03 '15, 3:24 a.m.

Thanks Francesco,

This afternoon I reset my VM and started the server from a just installed state. I noticed some errors involving truncated logs in the LQE component so jumped in and reindexed the failing application (JTS) and then went straight to the DCC and tried to configure it.

This time it behaved itself perfectly.

Now I wonder if the DCC error is somehow related to the LQE error. Going to reset and try to duplicate the DCC problem again.


Rafik Jaouani commented Aug 05 '15, 12:00 p.m.
JAZZ DEVELOPER

Davyd, the resource groups you deleted probably had the wrong autentication type. If you want to use a user/password for authenticating make sure the authentication type is set to "Username and Password"

One other answer



permanent link
Davyd Norris (2022914) | answered Aug 03 '15, 3:28 a.m.
I guess the bigger question is - why are almost all of the out-of-the-box RQM reports still being driven off the Data Warehouse and will these be restructured over time?

The reports I tried to access during the demo were the two different defect listing reports, both of which could, and probably should, be driven directly off live data.

Your answer


Register or to post your answer.