It's all about the answers!

Ask a question

role assignment for "restrict changes to items" operation in "deliver phase 2"


Ralf Westphal (612) | asked Jun 08 '15, 2:53 p.m.
retagged Jun 19 '15, 3:45 p.m. by Ken Tessier (84117)

Hello,

I want to restrict the access to specific files in a stream by using the "restrict changes to items" operation in the "deliver phase 2" via the operation behavior setting of the process configuration. The idea was to first prevent the access to these files for the role "everyone (default)" and then allow the access to specific roles. However, this doesn't seem to work, as even for those team members of the role for which the access should be allowed, the system uses the configuration from the "everyone (default)" role and prevents the access.

Is there a way to achieve the behavior, that the system uses the role assigned to the user over the default role?

I'm using the RTC version 4.0.6

Thanks,

Ralf

One answer



permanent link
Geoffrey Clemm (30.1k23035) | answered Jun 08 '15, 8:18 p.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
Any explicitly defined role will be searched for operation behavior before the everyone(default) role is checked, so roles are searched in the order that you would expect.  But note that in order for the behavior setting for that role to supersede the everyone role setting, you have to have explicitly turn on that operation behavior for that role.   So is "preconditions and follow-up actions are configured for this operation" set for the specific role(s) for the "Deliver Phase 2 (server)" operation?   (If not, this role will be skipped, and it will keep searching for a role that does have behavior set for that operation, and will find it set in the everyone role).

Comments
Ralf Westphal commented Jun 13 '15, 2:20 p.m.

Thank you very much for your answer. I'm quite sure that I assigned the rights to the right role. But I'll check this again. Maybe the source of the problem was something different.

Your answer


Register or to post your answer.