It's all about the answers!

Ask a question

Fix CRJAZ1726E error when registering apps? SQLCODE=-401, SQLSTATE=42818


Caspar Krieger (17257) | asked Jan 07 '13, 4:41 a.m.
retagged Jan 07 '13, 10:24 a.m. by Laura W. Hinson (16126)
 I've installed Jazz 4.0.1 (JTS + RTC + Trial Licences) using the bundled Tomcat onto a single Windows Server 2008 install, using DB2 9.7 FP7 on another Server 2008 install, but it's failing to register applications; the following error message appears:

An error occurred while attempting to register the applications.ID CRJAZ1726E

Failed to claim content: com.ibm.team.repository.common.model.impl.ContentImpl@24782478 (internalId: [UUID _TpO8YlihEeKwiv3hXRpThQ]) (deltaPredecessor: null, contentId: [UUID _TpFLYlihEeKwiv3hXRpThQ], contentLength: 44, characterEncoding: UTF-8, contentType: text/plain, checksum: 1550847795, lineDelimiterSetting: 0, lineDelimiterCount: )ID CRJAZ0475I
<snipped - Full stack trace here: http://pastebin.com/Z51HPGNR>
Caused by:
DB2 SQL Error: SQLCODE=-401, SQLSTATE=42818, SQLERRMC==, DRIVER=4.14.88 (com.ibm.db2.jcc.am.SqlSyntaxErrorException)

The only unusual thing is I modified the server.xml config of Tomcat to use port 443 instead of 9443. I selected the standard 3.x/4.x context roots and they're correctly filled in with Application Instances of /ccm and /admin with Discovery URLs of https://[domain name]:443/ccm/scr and https://[domain name]:443/admin/scr ; if I navigate to those URLs, I get a bunch of XML as I'd expect.

SQLCODE=-401, SQLSTATE=42818 is apparently (at least in DB2 v8) an error indicating The data types of the operands for the operation operator are not compatible. That's not particularly useful since I can't see the statement which was executed (or at least it isn't in the logs under server/logs/).

I get the same error when I click Run All Diagnostics on the JTS server diagnostics page.

How do I fix this so I can get my applications registered?

Accepted answer


permanent link
Lauren Hayward Schaefer (3.3k11127) | answered Jan 07 '13, 7:18 a.m.
JAZZ DEVELOPER
edited Jan 07 '13, 7:22 a.m.
Hi Caspar,
Are you using DB2 Express-C?  I found this release note that looks to have the same error message you're hitting:  https://jazz.net/library/article/1173/ .  The release note includes a workaround. 
Caspar Krieger selected this answer as the correct answer

Comments
Caspar Krieger commented Jan 07 '13, 9:49 p.m. | edited Jan 07 '13, 9:50 p.m.

Turns out I am indeed using DB2 Express-C 9.7; I must have grabbed the wrong download from Xtreme Leverage. I will try using the trial download on https://jazz.net/downloads/rational-team-concert/releases/4.0.1?p=optionalPrograms instead.

Your answer


Register or to post your answer.