It's all about the answers!

Ask a question

Not able to find conflicts in sync stream

Penchala suman (461325) | asked Apr 06 '15, 4:51 a.m.
 We are using ClearCase synchronizer doing sync streams between ClearCase and RTC. Synchronization was failing with warning message because of merge conflict, But when we flow CLONE workspace from sync workspace. We are not able to see any conflicts, even I checked in pending changes in CLONE nothing shows for conflicts. My workspace is accepted all incoming changes and up-to-date.

Any one excised this issue, if yes please give your suggestions.

One answer

permanent link
Geoffrey Clemm (30.1k33035) | answered Apr 06 '15, 11:25 a.m.
edited Apr 06 '15, 12:48 p.m.
The conflicts will appear in the "merge workspace" (which is created for you automatically when you create a synchronization stream).  In particular, the merge workspace will have two targets ... the synchronized stream and the CLONE* workspace.   To resolve the conflicts, you accept changes from both targets into the merge workspace, resolve any conflicts, and then deliver the results to the synchronized stream.

Just to confirm, you have not logged in as synchronizer account and manually modified your CLONE workspace in any way, correct?  (That would break that synchronization stream).

Penchala suman commented Apr 06 '15, 12:42 p.m.

Yes, I know we should not modify CLONE workspace. we are trying to find out Conflicts that's way i mentioned about CLONE.

we are not able to find any changes in merge workspace. no clue where the conflicts exist and how to find those files. 
we have been using around 1 year this synchronization we had resolved so many conflicts, but this time we are hard to find what file is creating the conflicts.

Geoffrey Clemm commented Apr 06 '15, 12:53 p.m.

Have you tried creating a new "merge workspace"?   To do so, using your normal user account (not the synchronization account), create a workspace on the synchronized stream, add the CLONE workspace as a flow target, and switch the flow target of the new merge workspace to be the CLONE workspace.   Do you see any incoming changes in the Pending Changes view, and if so, are any of them marked as conflicts?

Penchala suman commented Apr 09 '15, 6:59 a.m. | edited Apr 09 '15, 4:51 p.m.

We have checked in new merge workspace with sync account and jazz admin account, but it did not show conflicts. What we observed after lot of testing, synchronization is happening from CC to RTC, But RTC to CC is not working and sync is failing with “Merge required (accept changes from CLONE workspace).

1.       If I modify any file in ClearCase, once I run synchronization the file will update in RTC, even if I create a new conflict then it show as conflict in RTC, once I resolve the conflict in workspace then again sync will fail with same message. <o:p> </o:p>

2.       If I modify any file in RTC, once I run the synchronization it is not reflecting the changes in CC. <o:p> </o:p>

3.       Seems to be something is blocking the sync from RTC to CC. <o:p> </o:p>

Geoffrey Clemm commented Apr 09 '15, 4:58 p.m.

When you say "checked in new merge workspace", I assume you mean "created a new merge workspace", right?   (We use "check in" to refer to the operation on a modified file/directory to create a new version of that file or directory, not the operation that creates a new repository workspace.).
I am concerned when you say "with sync account and jazz admin account".   A merge workspace should be created from (and owned by) a normal user, not the sync account or a jazz admin account.  When you say "file will update in RTC", it is expected that the change from CC will show up in the CLONE workspace, but it should not be showing up in the synchronized stream if a conflict is being reported. 
You didn't say anything about what is showing up in the merge workspace, after you accept all changes from the CLONE workspace and from the synchronized stream.  That is where you expect to see the conflicts, and where you resolve them (but not in a merge workspace owned by the sync account).

Anbarasu Arivoli commented Apr 10 '15, 7:45 a.m.

Hi Geof,

To get more clarity on the above issue. 
1. The merge workspace is owned by the user and not the Sync account or Jazz admin account.
2. Whenever there are conflicts after the Synchronization we accept the changes from Clone to the Sync Stream and it appears in merge workspace. We resolve it in Merge workspace and deliver it. 
We did the whole exercise today during our remote session with IBM L3 Support. We were able to identify the conflicts and resolve and deliver it, but what happens after that is a mystery. After we run the Sync again the same warning message is displayed, but there are no changes to accept from Clone workspace. The point to be noted here is Synchronization is not happening on both ways, RTC to Clearcase is not happening and no files are being updated to Clearcase. How do we check this? Is there any quick workaround for this. Thanks, Anbu

Geoffrey Clemm commented Apr 10 '15, 5:04 p.m.

If a conflict is being reported, then it is expected that no changes would be sent back to ClearCase (since the Synchronizer never sends partial changes back to ClearCase, and since it does not know what to send back for the conflicts, it does not send anything back).  So not sending files back to ClearCase is expected.   The mystery is why it is still reporting a conflict after you have merged all the conflicts and delivered the merged results to the synchronized stream.   But I am intrigued ... how about sending me email at, and I can try to sit in on your next session with L3.

Penchala suman commented Jun 04 '15, 5:35 a.m.
IBM was provided HotFix, after install HF we were able to find the conflict file. actually the issue was file conflict, file was add in RTC and got sync to CC, then RTC side the same file was removed after the sync it say's conflict because CC sync expecting this file in RTC. It is bug in RTC so they have provide hotfix to find the file and we were able to find it and resolved the issue. 
showing 5 of 7 show 2 more comments

Your answer

Register or to post your answer.