It's all about the answers!

Ask a question

Jazz Reporting Service Out of the Box Templates, return no results


Brett Waldo (1101421) | asked Mar 28 '15, 1:08 a.m.
 Anyone had any luck running all of the out of the box reports for JRS? I can run some of them, but many (most) of them, just return "No results".  For example, change set activity. I know there has been activity on the stream selected in the query. 

RTC 5.0.2 iFix 003
JRS 5.0.2
Websphere
Oracle 11g

rs.log spits out tons of messages (sql queries), but nothing that looks like an error condition.

I don't know how else to troubleshoot this. 

Accepted answer


permanent link
Alanna Zito (1.3k3) | answered Mar 30 '15, 11:35 a.m.
JAZZ DEVELOPER
Hi Brett,

Have you enabled data collection on your streams?  This is necessary for the "Change Set Activity" report in particular.  To select streams to collect data for, go to

https:<server>:<port>/ccm/web/projects/<Your Project Name>#action=com.ibm.team.reports.admin&id=com.ibm.team.reports.admin.datawarehouse.scm

After you've selected which streams you want to enable, wait for the data collection jobs to run successfully before trying the report again. 

For the other out of the box reports, in addition to the things that Francesco mentioned, some of the reports return results from the current iteration only.  So if you're not seeing the data you expect (e.g., you're expecting a particular work item to show up in a report and it doesn't), check to see if it's assigned to the current iteration.


Brett Waldo selected this answer as the correct answer

Comments
Brett Waldo commented Mar 31 '15, 9:05 a.m.

 Thanks for the information. My streams where not marked properly from that page. I've updated it and re-ran the DW jobs, still nothing. I'm going to give it a day or two and see if it works after a few more collections+activity. 


Guido Schneider commented Mar 31 '15, 4:17 p.m.

BTW, each time the DCC data mart collector is running, you get a new baseline in the SCM. YOu should see them on the components.


Brett Waldo commented Apr 05 '15, 9:59 p.m.

 Alright, so I played with this a bit more and tracked it down to the stream that I am actually want data against (the one the team uses daily, the one I enabled for data collection) has its issoftdeleted flag set to 0 in the ridw.vw_file_stream table.  All the other streams have that field as 1.  The query in JRS requires the field to be 1. 


So, my question of course is, what next? What does this field mean? Is it set incorrectly, any ideas how it got set? Again, this stream is very active, used daily.



Alanna Zito commented Apr 06 '15, 9:27 a.m.
JAZZ DEVELOPER

When you run the report, are you not seeing your stream at all in the "Stream by Project" filter?  If so, I think I might know what's happening here - there was a bug in the Change Set Activity report in 5.0.2.  The query should actually be checking for issoftdeleted=0, not 1 (it indicates that something is deleted or archived).  So the field is set correctly for your stream, it's the report that's wrong.  This has been fixed in JRS 6.0; I'll find out if there's a way to get you a copy of the fixed report.  


Brett Waldo commented Apr 08 '15, 9:38 p.m.

 Alanna,

Thanks! That is correct, the stream I want does not even show in the pick list.  I would point out the streams that do show up (the ones with issoftdeleted = 1), are also valid streams that are not deleted and are also used pretty much daily.


Alanna Zito commented Apr 10 '15, 10:36 a.m.
JAZZ DEVELOPER

Re: issoftdeleted - my guess is that, in this particular case, issoftdeleted is meant to indicate streams that are not enabled for data collection, not that they're actually deleted.

I have a copy of the Change Set Activity report with the fix - it's in the form of a zip file that you could import into your server.  There doesn't seem to be a way to send a zip file via the forums; if you contact me at azito at ca dot ibm dot com, I can get it to you. .

showing 5 of 6 show 1 more comments

One other answer



permanent link
Francesco Chiossi (5.7k1719) | answered Mar 30 '15, 3:00 a.m.
edited Mar 30 '15, 3:02 a.m.
Hello Brett,

2 common causes for reports not returning data are the following:

1) The data was not collected into the data warehouse. Check the data warehouse tables and views involved in the report to see if there is data. To find the tables you can either use the SQL queries in the logs or the data dictionaries:

Reporting data dictionaries
http://www-01.ibm.com/support/knowledgecenter/SSYMRC_5.0.2/com.ibm.rational.reporting.overview.doc/topics/c_reference_datadictionary.html

Also check that the ETL process you are using (CLM data collection jobs, DCC or Insight Data Manager ETL) is successful.

2) The user that runs the report has no access to the project areas where the data comes from. Check that the user can access the projects.

Best Regards,

Francesco Chiossi

Comments
Brett Waldo commented Mar 31 '15, 9:29 a.m.

Ok, so I did as you suggested, and the SQL query returns no results. I only ran one test, the "Defects by Priority". The query has a JOIN on VW_REQUEST and VW_REQUEST_BINDING_TYPE on the REQUEST_TYPE_ID field. In my data, these never match. Every ID in VW_REQUEST is 36, but there are no occurrences of 36 in the BINDING_TYPE table.


So, what does this mean?


Alanna Zito commented Mar 31 '15, 9:51 a.m.
JAZZ DEVELOPER

Do you have a customized process template for your project area?  In the project area editor, go to Work Items -> Change Management Type Binding.  This page allows you to define the mappings between the specific work item types in your project and more generalized concepts.  The out of the box reports use these type bindings so that they can work with different process templates, instead of depending on the specific types.  Check the mapping for "Defect" - is it pointing to the right type?


Brett Waldo commented Mar 31 '15, 10:50 a.m.

 Ok, you guys are definitely helping. So that setting was indeed incorrect. I changed it to the type we deem a defect. Now what? Still nothing in the report or the sql query. I've run the DW jobs.


Do I need to wait a few days for this data to all be tied together? E.g. Is this for new "defects" going forward?


Alanna Zito commented Mar 31 '15, 11:29 a.m.
JAZZ DEVELOPER

How are you running the jobs?  Are you using DCC, or the data collection jobs within CLM?  If you're running within CLM, are you running all jobs from the JTS, or just the CCM jobs?   
I think updating the type bindings should take effect on all work items (not just for newly created ones).  Does the data look right in the BINDING_TYPE table after you run the jobs?  A couple of other things to check (these apply to a lot of the out of the box reports, not just Defects by Priority):

-The report (and query) returns data only from work items that are assigned to the current iteration by date (not by the iteration that is set as "current" in the timeline).  Double check the start/end dates of your iterations.
-The report is only looking for defects that are not in a 'closed' state.  Check the States section under Work Items -> Workflows in the project area editor.
-Are you selecting a team area in the report filters?  If so, try leaving it blank to see if you get any results that way.


Brett Waldo commented Mar 31 '15, 12:54 p.m.

 I just click the "Run all data warehouse collection jobs for all applications " @  https://<server>/jts/admin#action=com.ibm.team.reportsManagement.etlConfig


I just tried again (Defects by Priority) and it worked, so maybe I didn't give it enough time after the collection jobs.

I think all the reports work now except Change Set Activity. I need to play with that query and see why I get no results. I wasn't collecting data on that stream so it may take a day to collect. I'll post back when I know more.



Alanna Zito commented Mar 31 '15, 1:05 p.m. | edited Mar 31 '15, 1:05 p.m.
JAZZ DEVELOPER

Excellent.  That's the right way to run the jobs; just wanted to make sure.  One more thing I would mention is to make sure that the jobs have finished in all applications before looking for updated results in your reports.  If you look at the /jts/admin#action=com.ibm.team.reportsManagement.etlStatus page, it only shows the status of jobs running on the JTS; even if they're finished, there may still be jobs running in RTC (which you can check on the /ccm/admin#action=com.ibm.team.reportsManagement.etlStatus page). 

showing 5 of 6 show 1 more comments

Your answer


Register or to post your answer.