It's all about the answers!

Ask a question

installing rtc over eclipse Helios


josep rius (2817) | asked Jan 16 '15, 5:09 a.m.
I'm trying to install eclipse RTC 5.0.1 plug in over an already eclipse existing installation

exactly:
Eclipse Helios SR2 Packages (v 3.6.2)
eclipse-reporting-helios-SR2-win32-x86_64

and then, the plug in used from jazz web downloads page, plain zip files, p2 Install RepositoryAll (319.42 MB)
RTC-Client-p2Repo-5.0.1.zip

installing method, as usual, throuh Help>install new software> available software sites> etc etc

are the correct versions, should they match correctly?

One answer



permanent link
Ralph Schoon (56.0k23642) | answered Jan 16 '15, 5:21 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER
I installed 5.0.1 into Helios and it worked for me as far as I remember. The systems requirements link on the download for your version, tab "Release Notes" provides you with the compatibility information.

Comments
josep rius commented Jan 16 '15, 5:47 a.m. | edited Jan 16 '15, 8:52 a.m.

Thank you so much for the quick answer Ralph
but I was going to say that altough it seems to be all correct, about versions

eclipse doesn't starts anymore after installing it (even using a fresh installation and a new workspace),
it shows the message "" and output the following error log

!SESSION 2015-01-16 11:41:59.329 -----------------------------------------------eclipse.buildId=M20110210-1200java.version=1.7.0_01java.vendor=Oracle CorporationBootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=es_ESFramework arguments:  -product org.eclipse.epp.package.reporting.productCommand-line arguments:  -os win32 -ws win32 -arch x86_64 -product org.eclipse.epp.package.reporting.product -clean!ENTRY org.eclipse.osgi 4 0 2015-01-16 11:42:10.940!MESSAGE An error occurred while automatically activating bundle org.eclipse.core.resources (489).!STACK 0org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)    at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)    at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)    at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)    at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:33)    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:466)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)    at java.lang.ClassLoader.loadClass(Unknown Source)    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:116)    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)    at java.lang.reflect.Method.invoke(Unknown Source)    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)Caused by: java.lang.NoSuchMethodError: org.eclipse.core.internal.preferences.PreferencesService.getDefaultDefaultLookupOrder()[Ljava/lang/String;    at org.eclipse.core.resources.ResourcesPlugin.initializePreferenceLookupOrder(ResourcesPlugin.java:422)    at org.eclipse.core.resources.ResourcesPlugin.start(ResourcesPlugin.java:409)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)    at java.security.AccessController.doPrivileged(Native Method)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)    ... 29 moreRoot exception:java.lang.NoSuchMethodError: org.eclipse.core.internal.preferences.PreferencesService.getDefaultDefaultLookupOrder()[Ljava/lang/String;    at org.eclipse.core.resources.ResourcesPlugin.initializePreferenceLookupOrder(ResourcesPlugin.java:422)    at org.eclipse.core.resources.ResourcesPlugin.start(ResourcesPlugin.java:409)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)    at java.security.AccessController.doPrivileged(Native Method)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)    at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)    at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)    at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)    at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:33)    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:466)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)    at java.lang.ClassLoader.loadClass(Unknown Source)    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:116)    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)    at java.lang.reflect.Method.invoke(Unknown Source)    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)!ENTRY org.eclipse.osgi 4 0 2015-01-16 11:42:10.955!MESSAGE Application error!STACK 1java.lang.NoClassDefFoundError: org/eclipse/core/resources/IContainer    at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:116)    at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)    at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:369)    at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)    at java.lang.reflect.Method.invoke(Unknown Source)    at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:620)    at org.eclipse.equinox.launcher.Main.basicRun(Main.java:575)    at org.eclipse.equinox.launcher.Main.run(Main.java:1408)    at org.eclipse.equinox.launcher.Main.main(Main.java:1384)Caused by: org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter$TerminatingClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.core.resources (489).    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:121)    at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:453)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:216)    at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:393)    at org.eclipse.osgi.internal.loader.SingleSourcePackage.loadClass(SingleSourcePackage.java:33)    at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:466)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:422)    at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:410)    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:107)    at java.lang.ClassLoader.loadClass(Unknown Source)    ... 14 moreCaused by: org.osgi.framework.BundleException: Exception in org.eclipse.core.resources.ResourcesPlugin.start() of bundle org.eclipse.core.resources.    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:806)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:755)    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:370)    at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:284)    at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:417)    at org.eclipse.osgi.internal.loader.BundleLoader.setLazyTrigger(BundleLoader.java:265)    at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:106)    ... 23 moreCaused by: java.lang.NoSuchMethodError: org.eclipse.core.internal.preferences.PreferencesService.getDefaultDefaultLookupOrder()[Ljava/lang/String;    at org.eclipse.core.resources.ResourcesPlugin.initializePreferenceLookupOrder(ResourcesPlugin.java:422)    at org.eclipse.core.resources.ResourcesPlugin.start(ResourcesPlugin.java:409)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:783)    at java.security.AccessController.doPrivileged(Native Method)    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:774)    ... 29 more


1
Ralph Schoon commented Jan 16 '15, 5:59 a.m. | edited Jan 16 '15, 8:48 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

Sorry, I installed into Juno: https://rsjazz.wordpress.com/2014/09/09/getting-started-with-bluemix/ , not Helios.

I have to confess that these aliases are crap. I need to know the Eclipse version number and they are not telling. Helios is probably earlier than Juno and might not work. Did you follow my advice to check the release notes?



1
josep rius commented Jan 16 '15, 6:11 a.m. | edited Jan 16 '15, 8:48 a.m.

Thank you again,
I think "I took the bone" I'm looking right now

Eclipse IDE Notes

* If you are installing the Rational Team Concert Client into an existing instance of Eclipse IDE 3.6, please read this technote .


Krzysztof Kaźmierczyk commented Jan 16 '15, 6:22 a.m.

Your answer


Register or to post your answer.