It's all about the answers!

Ask a question

Eclipse Luna, Oracle Java 8, and RTC client


Irv Lustig (6111) | asked Jan 13 '15, 2:58 p.m.
I have Eclipse Luna installed, and using Oracle Java 8 (JDK 1.8.0_25) for development, and have some existing code.  I installed the RTC Client 5.0.2 from the p2 repository, and the installation seems to mess up the Eclipse execution environments saying that all Java code should require Java 1.7.

Is this a known problem?  Any idea as to how to extend Luna while using Java 8?
 

6 answers



permanent link
Francois-xavier Panaget (58914) | answered Jan 13 '15, 5:51 p.m.
Hi Irv,

The RTC client version 5.0.2 supports for Luna SR1 (4.4.1) in its system requirements but does not support yet the Java SDK 8. This is probably because IBM has not yet release a Java 8 SDK.

Regards,
François

Comments
Irv Lustig commented Jan 14 '15, 9:16 a.m.

François:

I can understand that, but I don't understand why if I have both the Java SDK 7 and Java SDK 8 installed as JRE's in Luna SR1 (4.4.1), why installing RTC messes up the execution environments within Eclipse.  What happens is that the existing execution environments that point to both JDK 1.8.0_25 and JDK 1.7.0_67 (both from Oracle) prior to RTC client installation get messed up and there is no longer a pointer to JDK 1.8.0_25 within those execution environments.
    -Irv


Alan Sampson commented Jul 09 '15, 3:50 p.m.
JAZZ DEVELOPER

IBM go to some pains to only claim support for IBM Eclipse SDK [IES] 4.4.1 in the 5.0 system requirements document [https://jazz.net/wiki/bin/view/Deployment/CLMSystemRequirements50#B4_Eclipse_IDE_RTC_Eclipse_Clien]
Note that IES is technically not Eclipse Luna


permanent link
Donald Nong (14.5k414) | answered Jul 01 '15, 7:55 p.m.
This can be the same issue raised in the below post. And the workaround is to downgrade Eclipse to Kepler.
https://jazz.net/forum/questions/184765/rtc-502-on-eclipse-luna-32bit

permanent link
Alex Fitzpatrick (5583816) | answered Jul 09 '15, 4:25 p.m.
JAZZ DEVELOPER
 Workaround is to force Eclipse to update to current JDT:

Once RTC is installed via p2:
1. Select Help > Install New Software... menu to open Install dialog.
2. Select "The Eclipse Project Updates - http://download.eclipse.org/eclipse/updates/4.4"
3. Expand the "Eclipse Java Development Tools" category
4. Select "Eclipse Java Development Tools"
5. Select "Next >" button
6. Install will detect that JDT is already installed and select an update instead.
7. Select "Next >" button
8. Select the "I accept the terms of the license agreement" radio button
9. Select "Finish" button
10. Installer will download updated plugins and features
11. Once the installer has completed you will be prompted to restart Eclipse, select "Yes"

Java compiler compliance should now be 1.8


permanent link
Rosa Naranjo (2.9k11723) | answered Jul 01 '15, 1:31 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
Irv
Please open a workitem on Jazz.net Rational Team Concert for this issue. There may be a workaround or it may be something to fix. 

However, Java 8 is not support with v5.0.2. It is supported with v6.0 which just became available. If you can try it with a v6.0 p2 package, please let us know what you find.

Comments
Irv Lustig commented Jul 08 '15, 10:34 a.m.

 I'm no longer interested in getting this fixed, as I'm not needing to use RTC within Eclipse.  But it is a bug that you ought to fix, as described in other responses below, the installation of RTC Client 5.0.2 on top of Luna messes up the installed execution environments within Luna.  So you can open up the work item!


permanent link
Norbert Schuld (1) | answered Jul 03 '15, 4:49 a.m.
edited Jul 03 '15, 5:20 a.m.
Tried eclipse Mars with RTC 6 plug-in, Java 8 still got disabled (was working before just fine).

Luna with RTC 6 seems to work :)

Comments
Alan Sampson commented Jul 09 '15, 3:59 p.m.
JAZZ DEVELOPER

I have a different experience.  I've installed the RTC 6.0 p2 repo. into Eclipse Luna (J2EE) and Eclipse Mars (J2EE) and have both working with Java 8 compiler compliance.


permanent link
Sreerupa Sen (1.0k4) | answered Jul 03 '15, 2:33 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
 I tried this out and it works for me. I tested on Windows 7 and with the IBM Java SDK.

- I installed Eclipse 4.4.2 (came with Java 7)
- then added a Java 8 SDK to the list of installed JREs. Checked that the compiler compliance level had 1.8. This was the IBM SDK, not Oracle.
- then installed RTC 5.0.2 from the p2 repo (I downloaded the p2 zip instead of installing directly from the update site though).
- then downloaded the multi-page editor sample that comes with Eclipse and it compiles just fine and my Java compiler compliance level is at 1.8 as before. 

Has anyone tried with IBM Java SDK, Eclipse 4.4.2 and RTC 5.0.2 and found issues with that?
Cheers
--Rupa 
RTC Clients

Comments
Donald Nong commented Jul 05 '15, 10:06 p.m.

What is the version of the JDT component after all the installations?


Sreerupa Sen commented Jul 06 '15, 2:17 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

       Eclipse Java Development Tools 3.10.1.v20150204-1700 org.eclipse.jdt.feature.group Eclipse.org


Donald Nong commented Jul 06 '15, 8:30 p.m.

That's quite interesting. I think in most failing cases, the JDT is replaced with the one bundled in RTC 5.0.2 (JDT 3.6.x), hence the Java 1.8 capability is lost.
Can you see if the installation steps can be repeated reliably (probably try with Oracle SDK as well)? If successful, that will be a workaround for many others.
(Note: IBM SDK cannot be obtained freely on Windows)


Sreerupa Sen commented Jul 08 '15, 1:23 p.m.
FORUM MODERATOR / JAZZ DEVELOPER

 Hi, 

    We've discussed this in the team, and we'd like to investigate what happens with Oracle JRE. Do you think you could open a defect  in jazz.net with your findings and point to it here? It'd be great if you would subscribe me (Sreerupa Sen, @sreerupa) in the work item.
    To answer your questions, I did try a number of times with IBM JDK on windows (which isn't available for download on its own) and it worked every time.
Cheers
--Rupa


Alex Fitzpatrick commented Jul 10 '15, 11:34 a.m.
JAZZ DEVELOPER

 Since the solution is to ensure JDT is updated, the defect would be in Eclipse, not RTC so there's no point in logging a defect against RTC.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.