It's all about the answers!

Ask a question

"zip file is empty" when installing RTC Eclipse plugin


Jorge Calderon (622) | asked Nov 12 '14, 10:09 a.m.

I'm trying to install the p2 eclipse plugin in Eclipse Luna version 32 bit on Linux. After selection the jar file and hitting finish, I get the error at the bottom.  I also tried extracting the file and reading the directory and get the same error. 

    An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase.
    session context was:(profile=epp.package.jee, phase=org.eclipse.equinox.internal.p2.engine.phases.CheckTrust, operand=, action=).
    Error reading signed content.
    zip file is empty


Comments
Donald Nong commented Nov 12 '14, 9:14 p.m.

This post in Stack Overflow looks to be the same issue.
http://stackoverflow.com/questions/26874328/zip-file-is-empty-when-installing-rtc-eclipse-plugin
So are you still getting the same error?

One answer



permanent link
Jorge Calderon (622) | answered Nov 13 '14, 12:40 p.m.
edited Nov 13 '14, 12:43 p.m.
Reinstalled eclipse to get this working.  The ".eclipse" folder may need to be removed too, although I didn't see one in my Linux VM.

Your answer


Register or to post your answer.


Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.