It's all about the answers!

Ask a question

Client Java requirement for Rational Asset Manager 7.2.1


Noriyuki Egi (7411718) | asked Nov 06 '14, 6:53 a.m.
Hi,
Please let me confirm the client system requirement for Rational Asset Manager.

As far as I see the Knowledge Center, when using Java applet, the users need JRE 1.5 Update 6 or later, or 1.6 Build 3 or later. On the other hand, the Detailed System Requirements of RAM describes that IBM Runtime Environment, Java Technology Edition 6.0.9, 6.0.12 or 6.0.13.

Which Java environment does the client need for officially support?
I think that the description of the Detailed System Requirements is for server environment.

Thank you.

Accepted answer


permanent link
Sheng Liu (21) | answered Nov 06 '14, 10:29 p.m.
JAZZ DEVELOPER
Yes, the Detailed System Requirements of RAM describes that IBM Runtime Environment, Java Technology Edition 6.0.9, 6.0.12 or 6.0.13, which are actually talking about the server environment JDK version. For server's JDK version, we will claim that we support IBM SDK 7.0.7 along with 6.0.13 in the newest release on server. But I have to mention that ,usually, RAM runs using WebSphere's JDK, of course users could point their WebSphere's JDK to supported versions we claim, but few will do this. If we claim we support some versions of WebSphere, then of course RAM can run well using those WebSphere's JDK.
And for the web client of RAM, we will upgrade RAM to support Oracle Java 7 Update 65 in the newest release. I think it's better that the client install
Oracle Java 7 Update 65 to get the best support in the coming newest release.
Noriyuki Egi selected this answer as the correct answer

Comments
Noriyuki Egi commented Nov 06 '14, 11:58 p.m.

Hi Sheng,


Thank you very much! 

Your answer


Register or to post your answer.