It's all about the answers!

Ask a question

Error installing RTC 5.0.1 on Linux 6.4 64 bit: libgcc_s.so.1 must be installed for pthread_cancel to work


Mike Shkolnik (9657160143) | asked Oct 24 '14, 7:00 p.m.
Linux 64 64 bit
Trying to install RTC 5.0.1:

./userinstc -acceptLicense -dataLocation /tmp/silent-install/data -silent -showVerboseProgress -nosplash -input silent-install-server.xml

(same as I did when upgrading from 4.0.1 to 4.0.3 and from 4.0.3 to 4.0.6)
Error:
libgcc_s.so.1 must be installed for pthread_cancel to work

library does exist:
[jazzadm@sinudy73 lib64]$ ls libgcc* -la
-rwxr-xr-x. 1 root root 93320 Oct 11  2013 libgcc_s-4.4.7-20120601.so.1
lrwxrwxrwx. 1 root root    28 Apr 15  2014 libgcc_s.so.1 -> libgcc_s-4.4.7-20120601.so.1

Tried:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib64
no luck
also tried installing libgcc.i686 (32 bit driver) - got multi-version error (would not install)

Any ideas?

2 answers



permanent link
Isabel Murakami (3811414) | answered Oct 25 '14, 10:07 a.m.
Hi Mike,
I found this technote: http://www-01.ibm.com/support/docview.wss?uid=swg21666144, however seems that the solution there you had already tried - to use libgcc 32 bits. But it was expecting to find at /lib

Check all the LD_LIBRARY_PATH, maybe it is finding the 64 bits version or another copy before the 32 bits one.


permanent link
Mike Shkolnik (9657160143) | answered Oct 27 '14, 4:42 p.m.
Well, I feel a bit silly now. Perhaps if the error message had been more explicit... :) I had misinterpreted the multi-version error to mean that 32 and 64 bit versions could not be installed at the same time. Turns out the available gcc libraries for 64 bit and 32 bit were different versions - 64 bit was 4.4.7-4 and 32 bit was 4.4.7-3. I think that's what the error message was trying to tell me. My unix team found a 32 bit version of 4.4.7-4 and all is good (though we could also have solved it by uninstalling the 64 bit 4.4.7-4 and installing both 32 and 64 bit 4.4.7-3, since that version was already available to us in both formats).

Comments
Mike Shkolnik commented Oct 27 '14, 4:49 p.m.

And here is the not-terribly-explicit error, in case someone else goes searching for text from this.

Error:  Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.:

1. You have an upgrade for libgcc which is missing some dependency that another package requires. Yum is trying to solve this by installing an older version of libgcc of the different architecture. If you exclude the bad architecture yum will tell you what the root cause is (which package requires what). You can try redoing the upgrade with --exclude libgcc.otherarch ... this should give you an error message showing the root cause of the problem.

2. You have multiple architectures of libgcc installed, but yum can only see an upgrade for one of those arcitectures. If you don't want/need both architectures anymore then you can remove the one with the missing update and everything will work.

3. You have duplicate versions of libgcc installed already. You can use "yum check" to get yum show these errors.


Your answer


Register or to post your answer.