It's all about the answers!

Ask a question

I have got an error information CRJAZ1675E. But what does it mean?

Martin Samuelsen (2357) | asked Oct 17 '14, 6:55 a.m.
retagged Oct 17 '14, 9:07 a.m. by Laura W. Hinson (16126)
I am using CLM version 5.0.1 on a Jazz webserver. In the Quality Management module in the Top ribbon you can choose 'Requirements'. If I click on that it tells me "Log in to view this content". If I click again then I get a very long error message:

The following problems occurred during the initialization process: CRJAZ1675E At least one service type must be specified at at at at sun.reflect.GeneratedMethodAccessor1292.invoke(Unknown Source) at sun.reflect.DelegatingMethodAccessorImpl.invoke( at java.lang.reflect.Method.invoke( at org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.invoke( at org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord.access$0( at org.eclipse.soda.sat.core.internal.record.ExportProxyServiceRecord$ExportedServiceInvocationHandler.invoke( at com.sun.proxy.$Proxy1727.service(Unknown Source) at at at at$0( at$1.service( at$ at at javax.servlet.http.HttpServlet.service( at org.eclipse.equinox.http.registry.internal.ServletManager$ServletWrapper.service( at org.eclipse.equinox.http.servlet.internal.ServletRegistration.service( at org.eclipse.equinox.http.servlet.internal.ProxyServlet.processAlias( at org.eclipse.equinox.http.servlet.internal.ProxyServlet.service( at javax.servlet.http.HttpServlet.service( at org.eclipse.equinox.servletbridge.BridgeServlet.service( at at javax.servlet.http.HttpServlet.service( at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at at at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter( at org.apache.catalina.core.ApplicationFilterChain.doFilter( at org.apache.catalina.core.StandardWrapperValve.invoke( at org.apache.catalina.core.StandardContextValve.invoke( at org.apache.catalina.authenticator.AuthenticatorBase.invoke( at org.apache.catalina.core.StandardHostValve.invoke( at org.apache.catalina.valves.ErrorReportValve.invoke( at org.apache.catalina.authenticator.SingleSignOn.invoke( at org.apache.catalina.core.StandardEngineValve.invoke( at org.apache.catalina.connector.CoyoteAdapter.service( at org.apache.coyote.http11.AbstractHttp11Processor.process( at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process( at$ at java.util.concurrent.ThreadPoolExecutor$Worker.runTask( at java.util.concurrent.ThreadPoolExecutor$ at org.apache.tomcat.util.threads.TaskThread$ at CRJAZ1675E At least one service type must be specified 400

Does anyone knows what this means and what should I do to correct it so that I can fix the problem?

Accepted answer

permanent link
Ralph Schoon (63.0k33645) | answered Oct 20 '14, 7:59 a.m.

I could not figure out what the reason for this error is either. See

My interpretation is that there is a service discovery request against a server and there is no service specified.

I would consider creating an enhancement request to get the error description enhanced.
Martin Samuelsen selected this answer as the correct answer

Martin Samuelsen commented Oct 20 '14, 9:20 a.m.

Hi Ralph,
I will do an enhancement request as you had advised.

4 other answers

permanent link
Diane Everitt (27835) | answered Dec 22 '14, 2:37 p.m.

It seems the project association was somehow modified after the migration.

The workaround is to create the link between the RQM project and the RRC project again. Links should work after that.

Note that you may need to open RRC and remove the connection.  Then add the RRC project from RQM > Manage This Project Area.

Also note that removing the project links does not remove the links in the actual artifacts.

I hope this helps.

Best regards,

Martin Samuelsen commented Jan 15 '15, 9:17 a.m.

Hi Diane,
Thank you very much for your feedback which we implemented and now you fixed our issue. Thanks :-)

permanent link
Christopher Robinson (571817) | answered Jun 08 '15, 12:49 p.m.
Diane Everitt's suggestion to delete and recreate the project links resolved my clients instance of the above also. Thanks Diane!

permanent link
Kiran Byrappa (1114) | answered Jul 17 '15, 2:46 a.m.

I had an instance where upgrade from 4.x to 5.x lead to the same error and it was resolved after removing and add the RQM-RM association again. The above solution worked !!!

But question is if there are many such projects linked, it will be tedious to achieve this.
Any suggestion to implement this on multiple projects in a single go?

permanent link
Brett Bohnn (94111148) | answered Oct 14 '15, 11:39 a.m.

I just worked with a client with same error after an upgrade from 4.0.5 to 5.0.2.

In this case, there was a clear problem in the repotools-rm_rmUpdateProjectBackLinksOnline.log

2015-05-12 11:35:20,080 CRJAZ1357E The repotools command could not log in to the following server: Check the login credentials.
2015-05-12 11:35:20,080
java.lang.NullPointerException at$1RemoteServiceProvider.getService(

It looks like the rm server was not online when 'repotools-rm -rmUpdateProjectBackLinksOnline' was run during the upgrade.

We simply re-ran that command listed in the repotools log, e.g.

repotools-rm -rmUpdateProjectBackLinksOnline adminPassword=*********** adminUserId=jazzadmin repositoryURL=https://myrdngserver:9443/rm

and repotools can successfully, updating links for all projects. We were then able to access the requirements drop-down from all RQM project areas.

So, before you remove the association, if you just upgraded, ensure that 'repotools-rm -rmUpdateProjectBackLinksOnline' ran to completion.


Your answer

Register or to post your answer.