It's all about the answers!

Ask a question

How to solve Error invoking default value provider


Nicolas Dangeville (3062025) | asked Oct 31 '13, 7:07 a.m.
JAZZ DEVELOPER
edited Nov 04 '13, 5:42 p.m. by Stephanie Taylor (24115)
We have a RTC server which log has plenty of entries like this one:

2013-10-29 11:56:00,281 [jazz: AsynchronousTaskRunner-11 @@ 11:56] ERROR com.ibm.team.workitem.common                        - Error invoking default value provider 'com.ibm.team.workitem.valueproviders.DEFAULT_VALUE_PROVIDER._0mQwEGY0EeKwGvsbtge-Rw'
java.lang.IllegalArgumentException: Default iteration configured but value not present in configuration (Work Item -1, Attribute 'Planned For')
    at com.ibm.team.workitem.common.internal.attributeValueProviders.CustomDefaultIterationProvider.getDefaultValue(CustomDefaultIterationProvider.java:26)
    at com.ibm.team.workitem.common.internal.attributeValueProviders.CustomDefaultIterationProvider.getDefaultValue(CustomDefaultIterationProvider.java:1)
    at com.ibm.team.workitem.common.internal.attributeValueProviders.AttributeValueProviderRegistry$SafeDefaultValueProvider.getDefaultValue(AttributeValueProviderRegistry.java:112)
    at com.ibm.team.workitem.common.internal.model.impl.AttributeImpl.getDefaultValue(AttributeImpl.java:887)
    at com.ibm.team.workitem.common.internal.WorkItemCommon.createWorkItem(WorkItemCommon.java:236)
    at com.ibm.team.workitem.common.internal.WorkItemCommon.createWorkItem2(WorkItemCommon.java:205)

It's a RTC 4.03 server.

We have looked at the process configuration source and there's no mention of the string "_0mQwEGY0EeKwGvsbtge-Rw"

We'd like to resolve this because it fills the log and makes it difficult to identify real issues. Do you know what we should do ?

Many thanks


Comments
Naveen V commented Jan 19 '17, 4:37 p.m.

Hi,

Did you solve this issue? I am seeing the same error now?
Can you please help to solve this issue in my environment.

Thanks,
Om

Accepted answer


permanent link
Ian Wark (7812944) | answered Nov 04 '13, 11:58 p.m.
I think this kind of error can be caused by attribute customization when the script defined is not working properly. Did you create a default value / calculated value etc. for a work item or something similar?

It might be worthwhile checking when the error started occurring in the log and then check the process configuration xml in history for a change that occurred at that time.

What changes did you make at the time the error started occurring in the log? Anything to do with iterations? Did you add or remove iterations?

If this is an urgent problem, it might be better to export your process configuration and raise PMR to have it investigated. Do you have any other symptoms of something broken in that project area?


Ralph Schoon selected this answer as the correct answer

One other answer



permanent link
Naveen V (79135) | answered Jan 20 '17, 10:11 a.m.

I resolved this by deleting the default --calculated value

go to eclipse client --> connect to project area
open process configuration --> project configuration --> configuration data --> work items --> attribute customization --> default values there it mentioned default value where we are not using it.

It solved the problem. May be it is useful for others when they get this error.


Comments
Ralph Schoon commented Jan 20 '17, 10:35 a.m.
FORUM ADMINISTRATOR / FORUM MODERATOR / JAZZ DEVELOPER

You could also have fixed the default value. Deletion however is also a way.

Your answer


Register or to post your answer.