It's all about the answers!

Ask a question

CRJAZ6055E/Stale Data

Mark Castro (741019) | asked Jul 29 '14, 12:54 p.m.
Hi all, very rarely we receive the following in Work items:

The operation cannot be run because the repository contains a newer version of the item it tried to modify. Refresh from the repository and try the operation again. For more details, open the help system and search for CRJAZ6055E.

We try to manually refresh the work items in question, but it seems to be something that is resolved on its own in the backend (sometimes after 1-2 days, sometimes a week).

Do you know if there's a way to manually sync these work items in question? Thanks for any help!

One answer

permanent link
Ralph Schoon (62.7k33643) | answered Jul 30 '14, 3:46 a.m.

I have seen stale data only when I created automation/extensions in the case that the data of the work item I tried to modify was modified in the meantime. In this case you have to refresh the work item before doing the change and refreshing. I am not sure if that could be the case for you as well. It would be good to understand better, when that happens (and in which version). I don't think you can run an operation to fix this, because this should only ever happen if you have conflicting changes on one work item.

sam detweiler commented Jul 30 '14, 6:59 a.m.

this has been reported before..

I have experienced it multiple times.

restarting the ccm server has been the only way to resolve it.

Mark Castro commented Aug 03 '14, 6:44 p.m.

Thanks Ralph/Sam. We're on 4.0.3 and havent noticed a pattern yet (happens rarely). Refreshing didn't resolve. Going by Sam's note we would need to restart to resolve. (likely won't be able to for 1 impacted work item however) Thanks!

Your answer

Register or to post your answer.